Bug 1128460 - Staypuft deployment with NFS backend for Cinder doesn't fill the share on the config file
Summary: Staypuft deployment with NFS backend for Cinder doesn't fill the share on th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: 5.0 (RHEL 6)
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ga
: Installer
Assignee: Scott Seago
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-10 15:48 UTC by Ido Ovadia
Modified: 2014-08-21 18:08 UTC (History)
3 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.2.5-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-21 18:08:45 UTC


Attachments (Terms of Use)
Screenshot or setting (82.41 KB, image/jpeg)
2014-08-11 14:15 UTC, Tzach Shefi
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1090 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2014-08-22 15:28:08 UTC

Description Ido Ovadia 2014-08-10 15:48:31 UTC
Description of problem:
=======================
Staypuft deployment  with NFS backend for Cinder doesn't fill the share on /etc/cinder/shares-nfs.conf

Version-Release number of selected component:
=============================================
ruby193-rubygem-staypuft-0.1.22-1.el6ost.noarch

How reproducible:
=================
100%


Steps to Reproduce:
===================
1. Deploy openstack with Staypuft on one bare metal
2. On Service Configuration --> Cinder choose NFS
3. Enter NFS URI
4. Submit
5. Deploy

Actual results:
===============
vi /etc/cinder/shares-nfs.conf is empty

Expected results:
=================
/etc/cinder/shares-nfs.conf shoult contain the NFS URI


Workaround:
===========
Manualy edit /etc/cinder/shares-nfs.conf, enter <server>:<local path>

Comment 3 Tzach Shefi 2014-08-11 14:15:19 UTC
Created attachment 925775 [details]
Screenshot or setting

Comment 4 Tzach Shefi 2014-08-11 14:15:51 UTC
Testing this again today, my deployment failed due to other reason. 
Looking around on Advanced configuration tab under cinder nfs I noticed: 
Cinder nfs shares []
Cinder nfs mount options  nosharecache

Note first one is blank, yet I'm sure I configured Cinder nfs usage (192.168.0.1:/cinder), is this expected or related to this bug?
Attached screen shoot comment 3.

Comment 5 Scott Seago 2014-08-11 17:20:53 UTC
https://github.com/theforeman/staypuft/pull/263

Comment 8 Omri Hochman 2014-08-19 11:08:42 UTC
Verified with: ruby193-rubygem-staypuft-0.2.5-1.el6ost.noarch 
( puddle 2014-08-15.1)
 
vi /etc/cinder/shares-nfs.conf --> 192.168.0.1:/cinder

Comment 9 errata-xmlrpc 2014-08-21 18:08:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1090.html


Note You need to log in before you can comment on or make changes to this bug.