This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 112847 - up2date client lists a package which can't be installed
up2date client lists a package which can't be installed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: 130798
  Show dependency treegraph
 
Reported: 2004-01-03 18:21 EST by Geoff Hart
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A list of RPMs currently installed on my system (51.26 KB, text/plain)
2004-01-03 18:24 EST, Geoff Hart
no flags Details

  None (edit)
Description Geoff Hart 2004-01-03 18:21:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I have a laptop running RHEL WS 3.0 with all the updates applied
except the most recent kernel patch.

The RedHat icon always shows as having outstanding patches waiting
(red icon), but the only patch available is a kernel patch which I
can't apply. This appears to be related to this particular patch being
released (which I installed) and then re-released with the same
name/version number, so it is conflicting with itself when I try to
install it.

When I load the up2date client, I get a notification that the
following package needs to be updated:
Package Name: kernel
Version: 2.4.21-4.0.1E
Old Version: 2.4.21-4.0.1E
Arch: i686
Size: 6992 kB
Channel: rhel-i386-ws-3

When I try to install it, I get an error saying: "Test install failed
because of package conflicts: package kernel-2.4.21-4.0.1.EL is
already installed"

Version-Release number of selected component (if applicable):
up2date-4.0.1-1

How reproducible:
Always

Steps to Reproduce:
This will be tricky to reproduce.. I got into this situtation by
installing the kernel-2.4.21-4.0.1.EL update when it was initially
released and then having the up2date client pick it up again when it
was re-released, but be unable to installed it since it has the same
name/version and thus conflicts with the original release.

For me, I can reproduce it by going into the up2date client and trying
to update the kernel pacakge.

Actual Results:  Test install failed because of package conflicts:
package kernel-2.4.21-4.0.1.EL is already installed

Expected Results:  Either the package shouldn't be listed in up2date
as needing to be installed or it should install correctly.

Additional info:
Comment 1 Geoff Hart 2004-01-03 18:24:29 EST
Created attachment 96753 [details]
A list of RPMs currently installed on my system

Output from "rpm -qa --last"

I believe the only RPM that wasn't installed with up2date or the initial
installer was the most recent mozilla-mail RPM. Everything else was installed
by default or installed as errata from RHN.
Comment 2 RHEL Product and Program Management 2007-10-19 15:31:49 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.