Bug 1128523 - puppet: service puppet start failed
Summary: puppet: service puppet start failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.5.0
Assignee: Douglas Schilling Landgraf
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: rhevh-7.0
TreeView+ depends on / blocked
 
Reported: 2014-08-11 02:41 UTC by haiyang,dong
Modified: 2016-02-10 20:11 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:01:15 UTC
oVirt Team: Node


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 33000 master MERGED rhevh7-post: keep files in /var/lib/puppet Never

Description haiyang,dong 2014-08-11 02:41:39 UTC
Description of problem:
Using edit-node install ovirt-node-plugin-puppet into rhev-hypervisor7-7.0-20140807.0.iso and clean install this
iso .Login it and enter into puppet page, configure 
Puppet Serverhcp-10-88.nay.redhat.com
Puppet Certificate Name: dhcp-73-241.nay.redhat.com

after clicking "Save" button to apply this configuration. check that: 
[root@agent2 admin]# cat /etc/puppet/puppet.conf |more
[main]
    server = "dhcp-10-88.nay.redhat.com"
    certname = "dhcp-73-241.nay.redhat.com"
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet
.....

But service puppet start failed:
[root@dhcp-73-241 admin]# service puppet start
Redirecting to /bin/systemctl start  puppet.service
[root@dhcp-73-241 admin]# service puppet status
Redirecting to /bin/systemctl status  puppet.service
puppet.service - Puppet agent
   Loaded: loaded (/usr/lib/systemd/system/puppet.service; disabled)
   Active: failed (Result: exit-code) since Sun 2014-08-10 07:43:26 UTC; 834ms ago
  Process: 4632 ExecStart=/usr/bin/start-puppet-agent agent ${PUPPET_EXTRA_OPTS} --no-daemonize (code=exited, status=1/FAILURE)
 Main PID: 4632 (code=exited, status=1/FAILURE)

Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:25 dhcp-73-241.nay.redhat.com start-puppet-agent[4632]: Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb...irt.rb
Aug 10 07:43:26 dhcp-73-241.nay.redhat.com puppet-agent[4633]: Starting Puppet client version 3.6.2
Aug 10 07:43:26 dhcp-73-241.nay.redhat.com puppet-agent[4633]: Could not run: Could not create PID file: /var/run/puppet/agent.pid
Aug 10 07:43:26 dhcp-73-241.nay.redhat.com systemd[1]: puppet.service: main process exited, code=exited, status=1/FAILURE
Aug 10 07:43:26 dhcp-73-241.nay.redhat.com systemd[1]: Unit puppet.service entered failed state.
Hint: Some lines were ellipsized, use -l to show in full.

Also append the output of "puppet agent --test" in here:
[root@dhcp-73-241 admin]# puppet agent --test
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Notice: Using less secure serialization of reports and query parameters for compatibility
Notice: with older puppet master. To remove this notice, please upgrade your master(s) 
Notice: to Puppet 3.3 or newer.
Notice: See http://links.puppetlabs.com/deprecate_yaml_on_network for more information.
Info: Retrieving pluginfacts
Error: /File[/var/lib/puppet/facts.d]: Failed to generate additional resources using 'eval_generate': Error 400 on SERVER: Not authorized to call search on /file_metadata/pluginfacts with {:links=>"manage", :recurse=>true, :ignore=>[".svn", "CVS", ".git"], :checksum_type=>"md5"}
Error: /File[/var/lib/puppet/facts.d]: Could not evaluate: Could not retrieve file metadata for puppet://dhcp-10-88.nay.redhat.com/pluginfacts: Error 400 on SERVER: Not authorized to call find on /file_metadata/pluginfacts with {:links=>"manage", :source_permissions=>"use"}
Wrapped exception:
Error 400 on SERVER: Not authorized to call find on /file_metadata/pluginfacts with {:links=>"manage", :source_permissions=>"use"}
Info: Retrieving plugin
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Info: Caching catalog for dhcp-73-241.nay.redhat.com
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /usr/share/ruby/vendor_ruby/puppet/type.rb:816:in `set_default')
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Error loading fact /usr/share/ruby/vendor_ruby/facter/operatingsystem.rb: cannot load such file -- ovirt.rb
Info: Applying configuration version '1407612446'
Notice: Finished catalog run in 0.16 seconds


Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.0-20140807.0.iso
ovirt-node-3.1.0-0.6.20140731git2c8e71f.el7.noarch
puppet-3.6.2-2.el7.noarch
ovirt-node-plugin-puppet-3.1.0-0.7.20140806gitef5c5cb.el7.noarch

How reproducible:
100% 
 
Steps to Reproduce:

Actual result:
service puppet start failed

Expect result:
service puppet start success

Additional info:
No this issue in the follow version
rhev-hypervisor6-6.5-20140725.0.el6ev
ovirt-node-plugin-puppet-3.0.1-18.el6.14.noarch
puppet-2.7.25-2.el6.noarch

so it's a regression bug

Comment 2 haiyang,dong 2014-11-17 13:03:58 UTC
Test version:
rhev-hypervisor7-7.0-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch
ovirt-node-minimizer-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch.rpm
ovirt-node-plugin-puppet-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch.rpm
ovirt-node-tools-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch.rpm


Test steps:
1. Insert a puppet plugin into iso.
2. Clean install the edited iso.
3. Enable Puppet in TUI.
   Enable Puppet         [x]

Puppet Server:             dhcp-8-166.nay.redhat.com_  
Puppet Certificate Name:   dhcp-66-73-112.englab.nay.redhat.com__

4.Clicking "<Save>" button

Test results:
Enable puppet success, also puppet functions work.
[root@dhcp-66-73-186 admin]# service puppet status
Redirecting to /bin/systemctl status  puppet.service
puppet.service - Puppet agent
   Loaded: loaded (/usr/lib/systemd/system/puppet.service; disabled)
   Active: active (running) since Mon 2014-11-17 12:54:31 UTC; 7min ago
 Main PID: 3363 (start-puppet-ag)
   CGroup: /system.slice/puppet.service
           ├─3363 /bin/sh /usr/bin/start-puppet-agent agent --no-daemonize
           └─3364 /usr/bin/ruby /usr/bin/puppet agent --no-daemonize

Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='osfamil...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='os', re...s
Nov 17 12:54:36 dhcp-66-73-186.englab.nay.redhat.com start-puppet-agent[3363]: Could not retrieve fact='osfamil...s
Nov 17 12:54:37 dhcp-66-73-186.englab.nay.redhat.com puppet-agent[3372]: Finished catalog run in 0.03 seconds
Hint: Some lines were ellipsized, use -l to show in full.

so this bug has been fixed in ovirt-node-plugin-puppet-3.1.0-0.25.20141107gitf6dc7b9.el7.noarch.rpm,change the status into "verified".

Comment 5 errata-xmlrpc 2015-02-11 21:01:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.