Bug 1128551 - [Article] Use PCI Passthrough and SR-IOV
Summary: [Article] Use PCI Passthrough and SR-IOV
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Martin Lopes
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
: 1051259 (view as bug list)
Depends On:
Blocks: rhelosp_sriov 1186518
TreeView+ depends on / blocked
 
Reported: 2014-08-11 05:20 UTC by Summer Long
Modified: 2015-02-13 05:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-13 05:53:51 UTC


Attachments (Terms of Use)

Description Summer Long 2014-08-11 05:20:05 UTC
Description of problem:
Need an article on how to use PCI Passthrough and SR-IOV

Comment 7 Martin Lopes 2014-10-31 04:43:23 UTC
First draft has been completed.

Comment 10 Itzik Brown 2014-11-25 08:18:02 UTC
Hi,
I have a few comments:

1. The topology supported is Network node on one node and compute nodes on other nodes

2. There is a limitation for now for using both OVS and SR-IOV on the same machine on the same network

3. I suggest adding an example how to use the SR-IOV (i.e. Using a port and then launching an instance with this port attached)

4. Using vnic_type=macvtap doesn't work for now

5. Section 1. - sriovnicswitch doesn't handle DHCP so openvswitch is a requirement when using the sriovnicswitch (or other MD which supports VLAN)

6. sriovnicswitch supports only VLAN 

7. Section 2. - Usually /etc/neutron/plugin.ini is pointing to /etc/neutron 
/plugins/ml2/ml2_conf.ini.
 Maybe it'll be good to point to the startup script

8. After changing the Neutron configuration files Neutron server should be restarted 

9. I suggest using Different sections for Neutron server , Neutron Agent (Optional) ,Nova configuration etc.

10. Section 3. Need some examples:
               a. An example for using PF in pci_whitelist
               b. Example with more than one physical network
               c. Example with sepcifying a subset of VFs (There is no regular expression or exclude                    option )

Comment 11 Stephen Gordon 2014-11-27 21:18:32 UTC
I would also like Brent to review this, we were discussing the other day and it seems there may also be some other configuration paths not covered on the upstream wiki that we need to document.

Comment 13 Itzik Brown 2014-12-22 08:13:33 UTC
Hi,
Will the document cover how to activate Virtual Functions in the network driver?

Comment 14 Martin Lopes 2014-12-23 04:47:27 UTC
Hi Itzik, 

Thanks for the feedback. I've added Virtual Functions to the article's todo list.

Cheers, 
Martin

Comment 17 Martin Lopes 2015-01-22 04:23:55 UTC
*** Bug 1051259 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.