Bug 1128648 - SMB:On Cifs mount creating files and doing list or running arequal checksum fills client log with "found anomalies for /.. gfid" issue
Summary: SMB:On Cifs mount creating files and doing list or running arequal checksum f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: gluster-smb
Version: mainline
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Raghavendra Talur
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1127658
TreeView+ depends on / blocked
 
Reported: 2014-08-11 09:49 UTC by Raghavendra Talur
Modified: 2015-05-14 17:43 UTC (History)
7 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1127658
Environment:
Last Closed: 2015-05-14 17:27:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2014-08-11 09:53:32 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Don't do force lookup for .. when parent is root.) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 2 Anand Avati 2014-08-11 09:58:36 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Don't do force lookup for .. when parent is root.) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 3 Anand Avati 2014-09-16 07:28:52 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Don't do force lookup for .. when parent is root.) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 4 Anand Avati 2014-09-18 12:23:53 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#4) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 5 Anand Avati 2014-09-18 12:40:12 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#5) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 6 Anand Avati 2014-11-03 07:19:36 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#6) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 7 Anand Avati 2014-11-03 07:30:08 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#7) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 8 Anand Avati 2014-11-14 03:50:12 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#8) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 9 Anand Avati 2014-11-14 05:18:36 UTC
REVIEW: http://review.gluster.org/8455 (gfapi: Change lookup logic for "/.." and "/." .) posted (#9) for review on master by Raghavendra Talur (rtalur@redhat.com)

Comment 10 Anand Avati 2014-11-14 07:34:54 UTC
COMMIT: http://review.gluster.org/8455 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 21282c0a7bf2783c8845335fe4834b043689ef0d
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Thu Sep 18 11:47:23 2014 +0530

    gfapi: Change lookup logic for "/.." and "/." .
    
    We should handle /.. and /. in unique way,
    otherwise we may end up setting glusterfs xattrs
    on parent of the brick dir.
    
    Change-Id: I206bb1751622bd912bc678fd52f4eddfd9b907c8
    BUG: 1128648
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/8455
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 11 Niels de Vos 2015-05-14 17:27:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 12 Niels de Vos 2015-05-14 17:35:32 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 13 Niels de Vos 2015-05-14 17:37:54 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 14 Niels de Vos 2015-05-14 17:43:05 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.