Bug 1128664 - association of subnet, domain, templates and resources to organization has no effect via CLI
Summary: association of subnet, domain, templates and resources to organization has no...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Tomas Strachota
QA Contact: sthirugn@redhat.com
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 10:38 UTC by Kedar Bidarkar
Modified: 2016-04-22 16:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:29:08 UTC


Attachments (Terms of Use)
foreman-debug for no association of entites for orgs (290.78 KB, application/x-xz)
2014-08-11 10:38 UTC, Kedar Bidarkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 7028 None None None 2016-04-22 16:44:02 UTC

Description Kedar Bidarkar 2014-08-11 10:38:38 UTC
Created attachment 925669 [details]
foreman-debug for no association of entites for orgs

Description of problem:

association of subnet, domain, templates and resources to organization has no effect via CLI.

Looks like there is no error message even via verbose and also in /var/log/foreman/production.log

a) resources

hammer -u admin -p changeme -v organization add-compute-resource --id=1 --compute-resource-id=$COMPUTERESOURCEID

b) subnet 
hammer -u admin -p changeme -v organization add-subnet --id=1 --subnet-id=$SUBNETID

c) domain
hammer -u admin -p changeme -v organization add-domain --id=1 --domain-id=$DOMAINID
 
d) template
hammer -u admin -p changeme -v organization add-config-template --id=1 --config-template-id=$id


Version-Release number of selected component (if applicable):
sat6-GA-snap4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Association of subnet, domain, templates and resources seem to fail 

Expected results:
Association of the above said entites must be successful.

Additional info:

Comment 1 Kedar Bidarkar 2014-08-11 10:51:29 UTC
I am sure it worked the last time when I tested here, 
https://bugzilla.redhat.com/show_bug.cgi?id=1089635

Wondering if this is a regression.

Comment 3 Bryan Kearney 2014-08-11 19:50:50 UTC
Created redmine issue http://projects.theforeman.org/issues/7028 from this bug

Comment 4 Justin Sherrill 2014-08-15 20:08:26 UTC
Note that:


 hammer -u admin -p changeme  os add-config-template --id=2 --config-template="Kickstart default iPXE"

Also does nothing (not sure if its the same cause or not)

Comment 5 Bryan Kearney 2014-08-27 16:03:58 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/7028 has been closed
-------------
Tomáš Strachota
https://github.com/Apipie/apipie-rails/pull/280
https://github.com/theforeman/foreman/pull/1707
https://github.com/Katello/katello/pull/4603
-------------
Anonymous
Applied in changeset commit:ce690b76c112fc50af8681a655b1f904d345afd2.

Comment 8 sthirugn@redhat.com 2014-08-28 20:50:50 UTC
Verified. Now the associations mentioned in the bug worked fine in CLI. But the success message is not displayed which will be tracked in an other bug https://bugzilla.redhat.com/show_bug.cgi?id=1135119

# hammer -u admin -p changeme -v organization add-compute-resource --id=6 --compute-resource-id=1

# hammer -u admin -p changeme -v organization add-subnet --id=6 --subnet-id=1

# hammer -u admin -p changeme -v organization add-domain --id=6 --domain-id=1

# hammer -u admin -p changeme -v organization add-config-template --id=6 --config-template-id=16

Version Tested:
GA Snap 7 - Satellite-6.0.4-RHEL-6-20140828.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.23-1.el6_5.noarch
* candlepin-common-1.0.1-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.23-1.el6_5.noarch
* candlepin-tomcat6-0.9.23-1.el6_5.noarch
* elasticsearch-0.90.10-6.el6sat.noarch
* foreman-1.6.0.42-1.el6sat.noarch
* foreman-compute-1.6.0.42-1.el6sat.noarch
* foreman-gce-1.6.0.42-1.el6sat.noarch
* foreman-libvirt-1.6.0.42-1.el6sat.noarch
* foreman-ovirt-1.6.0.42-1.el6sat.noarch
* foreman-postgresql-1.6.0.42-1.el6sat.noarch
* foreman-proxy-1.6.0.30-1.el6sat.noarch
* foreman-selinux-1.6.0.14-1.el6sat.noarch
* foreman-vmware-1.6.0.42-1.el6sat.noarch
* katello-1.5.0-30.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.62-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* openldap-devel-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-4.el6sat.noarch
* pulp-nodes-common-2.4.1-0.5.rc1.el6sat.noarch
* pulp-nodes-parent-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-puppet-tools-2.4.1-0.5.rc1.el6sat.noarch
* pulp-rpm-plugins-2.4.1-0.5.rc1.el6sat.noarch
* pulp-selinux-2.4.1-0.5.rc1.el6sat.noarch
* pulp-server-2.4.1-0.5.rc1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

Comment 9 Bryan Kearney 2014-09-11 12:29:08 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.