Bug 1128676 - [RFE] Spice: "cold" redirection of USB devices
Summary: [RFE] Spice: "cold" redirection of USB devices
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.4.0
Hardware: All
OS: Windows
medium
medium
Target Milestone: ---
: ---
Assignee: Scott Herold
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 11:07 UTC by Gajanan
Modified: 2019-04-28 10:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-05 08:44:20 UTC
oVirt Team: Spice


Attachments (Terms of Use)

Description Gajanan 2014-08-11 11:07:45 UTC
Description of problem:

USB auto redirection does not work in Windows 7 guest. 

First Scenario: 

When the USB is connected to the Client, it does not redirect automtically on the first time on the VM. We need to remove the usb and plug it in again then it works. 

>> Closed the spice console and opened it again, the issue remains the same, needs to do either the above step or the below step:. 

Second scenario:

We need goto File > USB Device Selection > Select USB device to redirect > then it works/detects the USB.  

>>> Customer wants to the USB to be detected automatically, it should not be re-plugged in again not to be selected manually from the USB device selection.

This issue was reproduced in customer's RHEV 3.4 environment as well as our lab environment on RHEV 3.3

Comment 1 Marc-Andre Lureau 2014-08-11 11:15:48 UTC
since there is an easy workaround, high/high is probably the wrong severity

Comment 3 Marc-Andre Lureau 2014-08-11 11:23:25 UTC
If I understand correctly, you want "cold" redirection, that is redirection of already plugged USB devices on client connection. 

by design, USB redirection is not done automatically on client connection.

Spice-gtk has a "redirect-on-connect" feature that can be used from command line. However there is no such settings from RHEVM afaik. I guess you should open an RFE if that's what you need.

Comment 21 Gajanan 2014-10-08 00:10:09 UTC
Hi,

1] I have updated regarding the comment #12 to the customer, and waiting for his updates on it. 

2] Secondly, about the customers expection here: currenlty when we do USB re-redirection i.e when the USB is connected to the Client, it does not detect it automatically,(USB) needs to be selected from the "USB Device Selection". Customer do not want to do this everytime. He wants this to be detected automatically. Please see description of problem for the customers expection here. 

Regards,
Gajanan


Note You need to log in before you can comment on or make changes to this bug.