Bug 1128680 - Spacewalk-utils missing dependency on spacewalk-reports
Summary: Spacewalk-utils missing dependency on spacewalk-reports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Transitions
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Tomas Lestach
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: stargate-GA-tracker
TreeView+ depends on / blocked
 
Reported: 2014-08-11 11:11 UTC by Lukáš Hellebrandt
Modified: 2017-02-23 21:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-01 12:27:11 UTC


Attachments (Terms of Use)

Description Lukáš Hellebrandt 2014-08-11 11:11:44 UTC
Description of problem:
The spacewalk-utils package contains a spacewalk-export tool. Spacewalk-export tool uses the spacewalk-report tool contained in spacewalk-reports package. Spacewalk-utils package doesn't have dependency on spacewalk-reports and the spacewalk-export tool fails with traceback without spacewalk-report tool installed.

How reproducible:
Always

Steps to Reproduce:
1. Install the spacewalk-utils package
2. Make sure the spacewalk-reports package is not installed
3. Run spacewalk-export

Actual results:

Traceback

[root@hostname]# spacewalk-export
INFO: Processing users...
Traceback (most recent call last):
  File "/usr/bin/spacewalk-export", line 302, in <module>
    globals()[entity.lower().replace('-','') + 'Dump'](options)
  File "/usr/bin/spacewalk-export", line 197, in usersDump
    _issueReport(options, 'users')
  File "/usr/bin/spacewalk-export", line 163, in _issueReport
    stdout = open(report_file, 'w'))
  File "/usr/lib64/python2.7/subprocess.py", line 524, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Expected results:
Spacewalk-export should create the export archive. It should either have spacewalk-report installed as a dependency or at least show some reasonable error message about missing spacewalk-reports package.

Comment 1 Tomas Lestach 2014-08-11 11:16:09 UTC
spacewalk.git: eea17f50153be2058fefa0ae82c8b6232f3d4b97

Comment 2 RHEL Product and Program Management 2014-08-11 11:23:43 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 5 Lukas Pramuk 2014-09-05 14:05:58 UTC
VERIFIED. spacewalk-utils-2.0.2-16.el6sat.noarch

# rpm -q --requires spacewalk-utils | grep spacewalk-reports
spacewalk-reports  

# rpm -e spacewalk-reports
error: Failed dependencies:
	spacewalk-reports is needed by (installed) spacewalk-utils-2.0.2-16.el6sat.noarch

Comment 6 Grant Gainey 2014-10-01 12:27:11 UTC
Released as part of Sat 6.0 GA


Note You need to log in before you can comment on or make changes to this bug.