Bug 1128689 - SELinux is preventing /usr/sbin/lsof from 'getattr' accesses on the unix_stream_socket .
Summary: SELinux is preventing /usr/sbin/lsof from 'getattr' accesses on the unix_stre...
Keywords:
Status: CLOSED DUPLICATE of bug 1128681
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2a1439166a6448d2258756c2567...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 11:21 UTC by Moez Roy
Modified: 2014-08-12 11:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 11:08:50 UTC


Attachments (Terms of Use)

Description Moez Roy 2014-08-11 11:21:30 UTC
Description of problem:
SELinux is preventing /usr/sbin/lsof from 'getattr' accesses on the unix_stream_socket .

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that lsof should be allowed getattr access on the  unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep lsof /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_cronjob_t:s0-s0:c0.c1023
Target Context                system_u:system_r:pcscd_t:s0
Target Objects                 [ unix_stream_socket ]
Source                        lsof
Source Path                   /usr/sbin/lsof
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           lsof-4.87-3.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-179.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.15.8-200.fc20.x86_64 #1 SMP Fri
                              Aug 1 00:38:50 UTC 2014 x86_64 x86_64
Alert Count                   7
First Seen                    2014-08-11 03:58:14 PDT
Last Seen                     2014-08-11 03:58:21 PDT
Local ID                      244e70f1-dbc7-4ec5-bb2d-32e2ea9928d2

Raw Audit Messages
type=AVC msg=audit(1407754701.640:1349): avc:  denied  { getattr } for  pid=4788 comm="lsof" path="socket:[15942]" dev="sockfs" ino=15942 scontext=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 tcontext=system_u:system_r:pcscd_t:s0 tclass=unix_stream_socket


type=SYSCALL msg=audit(1407754701.640:1349): arch=x86_64 syscall=stat success=no exit=EACCES a0=210c250 a1=7fff59f1d940 a2=7fff59f1d940 a3=0 items=0 ppid=1372 pid=4788 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4 comm=lsof exe=/usr/sbin/lsof subj=system_u:system_r:system_cronjob_t:s0-s0:c0.c1023 key=(null)

Hash: lsof,system_cronjob_t,pcscd_t,unix_stream_socket,getattr

Additional info:
reporter:       libreport-2.2.3
hashmarkername: setroubleshoot
kernel:         3.15.8-200.fc20.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2014-08-12 11:08:50 UTC

*** This bug has been marked as a duplicate of bug 1128681 ***


Note You need to log in before you can comment on or make changes to this bug.