Bug 1128697 - lightdm-gtk: missing icons
Summary: lightdm-gtk: missing icons
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lightdm-gtk
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 11:32 UTC by Jiri Kastner
Modified: 2015-03-25 14:27 UTC (History)
5 users (show)

Fixed In Version: lightdm-gtk-1.8.5-10.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-12 02:34:06 UTC


Attachments (Terms of Use)

Description Jiri Kastner 2014-08-11 11:32:33 UTC
Description of problem:
lightdm-gtk seems have not defined dependency on some icon theme and therefore when lightdm-gtk is installed standalone on top of minimal fedora install, instead of icons user can see only 'missing_icon' icon.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. install minimal fedora
2. install lightdm-gtk and if needed proper drivers for xorg
3. run systemctl start lightdm.service

Actual results:
missing icons

Expected results:
proper icons for all top level buttons

Additional info:

Comment 1 Rex Dieter 2014-08-11 12:09:27 UTC
<shrug>, that's the risk one takes with a minimal install sometimes, similar issues can happen for many things like fonts, locales, etc...

I'd rather avoid a hard-coded
Requires: gnome-icon-theme
if at all possible (since the required icons can theoretically be provided by any theme).

Comment 2 Rex Dieter 2014-08-11 16:21:19 UTC
On the other hand, seems the .spec already has:

# owner of HighContrast gtk/icon themes
Requires: gnome-themes-standard

So maybe something has changed recently.  I'll see what I can find out.

Comment 3 Rex Dieter 2014-08-11 16:23:17 UTC
And on my f20 box at least,

$ rpm -qR gnome-themes-standard
...
gnome-icon-theme


So either deps have changed, or the icons provided by gnome/HighContrast themes have changed/regressed.

Comment 4 Rex Dieter 2014-08-11 16:41:27 UTC
Indeed, gnome-themes-standard switched over to 
Requires: adwaita-icon-theme

in http://pkgs.fedoraproject.org/cgit/gnome-themes-standard.git/commit/?id=edc17bb52b815c2b804f49ea4e28aaf86a9de15d

And until when/if adwaita-icon-theme provides what we need, will have to continue relying on gnome-icon-theme.



%changelog
* Mon Aug 11 2014 Rex Dieter <rdieter@fedoraproject.org> 1.8.5-3
- missing icons, +Requires: gnome-icon-theme (#1128697)

Comment 5 Rex Dieter 2014-11-07 16:48:16 UTC
[11/07/14 10:43] <raveit65> rdieter, hi, are those runtime requires really needed for lightdm-gtk ? http://pkgs.fedoraproject.org/cgit/lightdm-gtk.git/tree/lightdm-gtk.spec#n54
[11/07/14 10:43] <rdieter_work> raveit65: yes, each requires has a comment explaining why
[11/07/14 10:44] <rdieter_work> raveit65: are you questioning something in particular?
[11/07/14 10:44] <raveit65> rdieter, i think all symbolic-icons which are needed for lightdm-gtk are in adwaitha-icon-theme
[11/07/14 10:45] <raveit65> rdieter, i did test it
[11/07/14 10:45] <rdieter_work> <nod> that could be true for f21+ now
[11/07/14 10:45] <rdieter_work> raveit65: can you file a bug so I don't forget?
[11/07/14 10:45] * rdieter_work is working on a bazillion other things atm
[11/07/14 10:45] <raveit65> rdieter, i ask because reducing size of livecd
[11/07/14 10:46] <raveit65> lightdm is the only package which pulls i the requires
[11/07/14 10:47] <raveit65> raveit65, file  out a report
[11/07/14 10:47] <rdieter_work> raveit65: nvm, I'll reopen the old one

Comment 6 Rex Dieter 2014-11-07 16:56:46 UTC
%changelog
* Fri Nov 07 2014 Rex Dieter <rdieter@fedoraproject.org> 1.8.5-10
- revert +Requires: gnome-icon-theme, adwaita reportedly good enough now (#1128697)

Comment 7 Wolfgang Ulbrich 2014-11-07 17:04:45 UTC
In detail i removed gnome-themes-standard and gnome-icon-theme with rpm ....--nodeps.
All needed symbolic icons are there which comes from adwaita-icon-theme in f21.
So using adwaita-icon-theme shopuld be enough.
Only the gtk2 part should be depend on gnome-icon-theme and adwaita-themes-gtk2 packages.
I would be great if we can can have a new build before livecd's are tagged for release.

Comment 8 Wolfgang Ulbrich 2014-11-07 17:05:47 UTC
hmm, gnome-icon-theme is only for the gtk2 needed, imo

Comment 9 Fedora Update System 2014-11-07 17:46:23 UTC
lightdm-gtk-1.8.5-10.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/lightdm-gtk-1.8.5-10.fc21

Comment 10 Fedora Update System 2014-11-10 06:33:25 UTC
Package lightdm-gtk-1.8.5-10.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-gtk-1.8.5-10.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14600/lightdm-gtk-1.8.5-10.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2014-11-12 02:34:06 UTC
lightdm-gtk-1.8.5-10.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Jiri Kastner 2015-03-24 15:51:06 UTC
in el7/centos7/epel7 is not adwaita-icon-theme available, problem is resolved with gnome-icon-theme-symbolic.
[root@gizmo2 ~]# rpm -q lightdm-gtk
lightdm-gtk-1.8.5-14.el7.x86_64

Comment 13 Rex Dieter 2015-03-24 18:42:39 UTC
I don't have any missing icons (using lightdm-1.8.5-14.el7), and I don't have gnome-icon-theme-symbolic installed.

Comment 14 Jiri Kastner 2015-03-24 19:55:58 UTC
i do not have clasiccal 'desktop' install, i just provisioned minimal rhel7 on usb stick and installed WindowMaker and lightdm.
and noticed missing 'settings' icon. i listed on another box, where i don't have missing 'setting' icon and i tried first package i didn't spotted on usb stick install. it was gnome-icon-theme-symbolic, after install restarted and icon appeared.

Comment 15 Rex Dieter 2015-03-25 14:27:31 UTC
ok, if my settings you mean the 'custom' item in sessions, then yes, I can reproduce.

I don't think it's worth adding a dependency (on gnome-icon-theme-symbolic) for that single issue though.


Note You need to log in before you can comment on or make changes to this bug.