Bug 1128704 - Innotop does not work with MariaDB 10
Summary: Innotop does not work with MariaDB 10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: innotop
Version: rawhide
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
Assignee: Fabio Alessandro Locati
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 11:34 UTC by Fabio Alessandro Locati
Modified: 2014-09-08 16:07 UTC (History)
2 users (show)

Fixed In Version: innotop-1.9.1-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-23 01:57:34 UTC


Attachments (Terms of Use)
Patch to fix the problem (4.39 KB, patch)
2014-08-11 11:34 UTC, Fabio Alessandro Locati
no flags Details | Diff

Description Fabio Alessandro Locati 2014-08-11 11:34:41 UTC
Created attachment 925707 [details]
Patch to fix the problem

Description of problem:
If you try to connect to a MariaDB 10 server, you will often receive errors, ie: "Use of uninitialized value $text in pattern match (m//) at /usr/local/bin/innotop line 620." if you try to go to transactions.

Version-Release number of selected component (if applicable):
All versions until 1.9.1 (included)

How reproducible:
Connecting to a MariaDB 10 server and press "T"


Steps to Reproduce:
1. connect to a MariaDB 10 server
2. press "T"

Actual results:
The app crashed

Expected results:
See the transaction list

Additional info:
I'm attaching the patch to the innotop.git repository to apply the patch (taken from Issue #93 if innotop upstream bug reporting tool)

Comment 1 Fedora Update System 2014-08-12 02:44:08 UTC
innotop-1.9.1-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/innotop-1.9.1-3.fc19

Comment 2 Fedora Update System 2014-08-12 02:44:15 UTC
innotop-1.9.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/innotop-1.9.1-3.fc20

Comment 3 Fabio Alessandro Locati 2014-08-12 08:33:43 UTC
This version is still not working. Seems like your patch is different than mine, have you applyied the patch to the repo or copied the file and cutted the end part?

Comment 4 Fabio Alessandro Locati 2014-08-14 21:52:17 UTC
I've requested commit access (https://admin.fedoraproject.org/pkgdb/package/innotop) to fix this matter and because, since the upstream project seems to be dead, more patches will come, given the fact that I use it at work daily and I need it to work properly.

Comment 5 Fedora Update System 2014-08-15 02:33:48 UTC
Package innotop-1.9.1-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing innotop-1.9.1-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9330/innotop-1.9.1-3.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-08-21 07:53:55 UTC
innotop-1.9.1-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/innotop-1.9.1-6.fc19

Comment 7 Fedora Update System 2014-08-21 07:54:51 UTC
innotop-1.9.1-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/innotop-1.9.1-6.fc20

Comment 8 Fedora Update System 2014-08-23 01:57:34 UTC
innotop-1.9.1-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-08-23 08:31:53 UTC
innotop-1.9.1-6.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/innotop-1.9.1-6.el6

Comment 10 Fedora Update System 2014-08-23 08:31:59 UTC
innotop-1.9.1-6.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/innotop-1.9.1-6.el5

Comment 11 Fedora Update System 2014-09-02 06:42:28 UTC
innotop-1.9.1-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-09-08 16:06:28 UTC
innotop-1.9.1-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-09-08 16:07:00 UTC
innotop-1.9.1-6.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.