Bug 1128724 - sourceStorageDoaminId parameter in MoveDisksParameters is redundant
Summary: sourceStorageDoaminId parameter in MoveDisksParameters is redundant
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: ---
Hardware: All
OS: All
unspecified
low vote
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Tal Nisan
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On: ovirt_refactor_disk_class_hierarchy
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 12:25 UTC by Vered Volansky
Modified: 2017-01-24 17:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 17:20:46 UTC
oVirt Team: Storage
amureini: ovirt-4.1?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)

Description Vered Volansky 2014-08-11 12:25:31 UTC
The source storage domain Id can be deducted from other parameters and unnecessarily overheads the API. This overhead is also a likely source to bugs and should be removed. Code that uses this should deduce the source storage domain id from the storage pool and disk.

Comment 1 Vered Volansky 2014-08-11 12:30:33 UTC
Live disks migration is affected by this change and should be verified to still be working against web-admin and REST API.

Comment 2 Allon Mureinik 2014-08-19 08:30:26 UTC
Should be re-examined after 3.6.0's disk refactoring.

Comment 3 Red Hat Bugzilla Rules Engine 2015-10-19 10:51:33 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Sandro Bonazzola 2016-05-02 10:08:40 UTC
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.

Comment 6 Yaniv Lavi 2016-05-23 13:23:55 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 7 Yaniv Lavi 2016-05-23 13:25:39 UTC
oVirt 4.0 beta has been released, moving to RC milestone.

Comment 8 Tal Nisan 2017-01-24 17:20:46 UTC
While the source storage domain can be implied from the image in a move image scenario can be implied (as currently we can only move VM disks which have exactly one copy) there are a couple of issues with this:
1. Having the parameters class call the data access layer to obtain the source storage domain is impossible and even if it would be possible this is discouraged
2. The MoveDisk parameters extend the MoveOrCopyDisk parameters which do require the source storage domain id for copy operations as a template disk can exist on a few storage domains
3. In the future we might want to add the ability to move a template disk from one storage domain to another and for that the source storage domain id will need to be supplied

Given all that the small benefit of removing this parameter doesn't worth the risk of regressions and future incompatibilities.


Note You need to log in before you can comment on or make changes to this bug.