Bug 1128726 - Evolution freeze during migration of pre-2.24 mails
Summary: Evolution freeze during migration of pre-2.24 mails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server
Version: 6.6
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 12:26 UTC by Jiri Koten
Modified: 2014-10-14 04:44 UTC (History)
4 users (show)

Fixed In Version: evolution-data-server-2.32.3-21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:44:04 UTC


Attachments (Terms of Use)
backtrace (4.53 KB, text/plain)
2014-08-11 12:26 UTC, Jiri Koten
no flags Details
eds patch (13.97 KB, patch)
2014-08-26 13:40 UTC, Milan Crha
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1418 normal SHIPPED_LIVE evolution-data-server bug fix and enhancement update 2014-10-14 01:06:29 UTC

Description Jiri Koten 2014-08-11 12:26:24 UTC
Created attachment 925717 [details]
backtrace

Description of problem:
Evolution freeze when restoring backup created on rhel5. The freeze happens in Migrating ... dialog during Migrating Folders

Version-Release number of selected component (if applicable):
evolution-2.32.3-33.el6
evolution-data-server-2.32.3-20.el6

How reproducible:
100%

Steps to Reproduce:
1. Restore backup created on rhel5


Actual results:
Evolution freeze

Expected results:
Migration is successful

Additional info:
Could be related or even a dupe of bz#1126916.

Comment 2 Matthew Barnes 2014-08-21 23:45:27 UTC
(In reply to Jiri Koten from comment #0)
> Additional info:
> Could be related or even a dupe of bz#1126916.

I don't think this one's related.  The backtrace suggests a deadlocked mutex in the migration code.  But that code is ancient and the migration to SQLite was always problematic.  I've long forgotten the details.

Comment 3 Milan Crha 2014-08-25 17:36:34 UTC
Hrm, this might be after a fix for bug #1040178.

Comment 4 Milan Crha 2014-08-26 13:40:32 UTC
Created attachment 930985 [details]
eds patch

for evolution-data-server;

CamelDB did not support nested transactions, while the database migration uses it. I added support for nested transactions in this patch, which fixes the deadlock. This is applicable to current upstream version as well.

Comment 7 errata-xmlrpc 2014-10-14 04:44:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1418.html


Note You need to log in before you can comment on or make changes to this bug.