Bug 112873 - Fatal: MediaGX graphics chipset incorrectly detected
Fatal: MediaGX graphics chipset incorrectly detected
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-01-04 20:50 EST by Chris Conrad
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-15 07:42:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Conrad 2004-01-04 20:50:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
When Anaconda detects the graphics chip set on my Geode GX1 based
computer for a grahpical install, it selects the MediaGX chipset,
instead of the '5530 Video [Kahula]'.  This leads to a fatal error.  I
am given no option to specify the correct driver to the installer, or
at least force a VGA compatibility mode.

 

Version-Release number of selected component (if applicable):
core1

How reproducible:
Always

Steps to Reproduce:
1.  Run the graphical install on a computer with the National Semi
Geode GX1.  It has a built in MediaGX type video processor.
2.  After it autodetects the video, keyboard, and mouse it tries to
start a graphical session but the screen goes blank and seems to crash
the system.
3.
    

Additional info:

Allow the user the option to manually set the video chipset driver
before the graphical install.
Comment 1 Jeremy Katz 2004-01-04 23:09:39 EST
Can you provide the output of /sbin/lspci -vn?
Comment 2 Chris Conrad 2004-01-20 07:22:08 EST
00:00.0 Class 0600: 1078:0001
Flags: bus master, medium devsel, latency 0

00:0e.0 Class 0200: 10ec:8139 (rev 10)
Subsystem: 10ec:8139
Flags: bus master, medium devsel, latency 32, IRQ 15
I/O ports at e000 [size=256]
Memory at d0000000 (32-bit, non-prefetchable) [size=256]
Capabilities: <available only to root>

00:12.0 Class 0601: 1078:0100 (rev 30)
Flags: bus master, medium devsel, latency 64

00:12.1 Class 0680: 1078:0101
Flags: medium devsel
Memory at 40012000 (32-bit, non-prefetchable) [size=256]

00:12.2 Class 0101: 1078:0102 (prog-if 80 [Master])
Flags: bus master, medium devsel, latency 0
I/O ports at f000 [size=16]

00:12.3 Class 0401: 1078:0103
Flags: bus master, medium devsel, latency 0
Memory at 40011000 (32-bit, non-prefetchable) [size=128]

00:12.4 Class 0300: 1078:0104
Subsystem: 1078:0001
Flags: medium devsel
Memory at 40800000 (32-bit, non-prefetchable) [size=8M]

00:13.0 Class 0c03: 0e11:a0f8 (rev 06) (prog-if 10)
Subsystem: 0e11:a0f8
Flags: bus master, medium devsel, latency 32, IRQ 15
Memory at d0004000 (32-bit, non-prefetchable) [size=4K]

Comment 3 Alan Cox 2004-07-12 10:26:02 EDT
Cyrix 5530 [Kahlua] is just the name of the 5530 PCI/companion chip on
the MediaGX. It is correct detection and should then use the "cyrix"
video driver.

Comment 4 Bill Nottingham 2004-07-12 16:24:00 EDT
Which it does, since 2001. Assuming a X driver problem for now.
Comment 5 Mike A. Harris 2004-07-12 17:31:14 EDT
Can you please manually try the "nsc" driver, and provide feedback
of wether it works or not on this chip?  If it does, I can map the
"1078:0104:1078:0001" to "nsc", which will hopefully work for everyone
out there.
Comment 6 Alan Cox 2004-07-12 17:46:26 EDT
It won't

The nsc driver is for VSA2 only. The mediagx driver is for VSA1 and
some VSA2. VSA being the virtual system architecture and thus part of
the BIOS firmware. There is a procedure for detecting VSA1 or VSA2 but
it is not PCI layer instead its a serious of I/O operations akin to
the vga "guess the video card" stuff, although always known safe by
the PCI id 
Comment 8 Mike A. Harris 2004-09-23 02:20:54 EDT
Flagging as FC3Target and taking assignment.
Comment 17 Mike A. Harris 2005-03-15 07:42:33 EST
Tracker filed in X.Org upstream bugzilla:

https://bugs.freedesktop.org/show_bug.cgi?id=2737

Setting status to "UPSTREAM"

Note You need to log in before you can comment on or make changes to this bug.