Bug 1128743 - [RFE] Please improve the UI design -- guest OS icons in the User Portal look outdated and should better be redesigned
Summary: [RFE] Please improve the UI design -- guest OS icons in the User Portal look ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Nobody
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 13:07 UTC by Yuko Katabami
Modified: 2019-04-28 13:25 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:56:22 UTC
oVirt Team: Virt
michal.skrivanek: ovirt-4.2?
sherold: Triaged+
pbrilla: testing_plan_complete-
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83301 None None None 2017-11-16 13:28:16 UTC
oVirt gerrit 83302 None None None 2017-11-16 13:27:29 UTC

Description Yuko Katabami 2014-08-11 13:07:19 UTC
Description of problem:
The guest OS icons in the User Portal look outdated and should better be redesigned. For example, if you choose SUSE Enterprise Linux Server 11, it will show VM with older SUSE icon with the label "Enterprise Server 2011".
RHEL 7 icon also does not look to represent the current design of RHEL7.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Login to User Portal
2. Create VM with different OS selected.
3. Check the icon in Virtual Machines tab.

Actual results:
Many of icon designs look outdated

Expected results:
Should be more up-to-date and better design.

Additional info:

Comment 1 Hajime Taira 2014-08-12 02:42:42 UTC
Additinal info:
RHEL Logo of Guest OS does not comply Red Hat Branding Guide.

Comment 2 Einav Cohen 2014-08-14 18:26:49 UTC
@Liz - the virt team will need the UXD team's assistance in order to update the OS icons / adjust them to the Red Hat Branding Guide. 

I am wondering if this is something that should wait for the GUI 4.0 overhaul, since currently, most of the RHEV-M GUI does not comply with the Red Hat Branding Guide anyway - the OS icons are only a tiny part of it. 

thanks.

Comment 3 Liz 2014-08-18 18:25:58 UTC
I agree, Einav. We will be updating the icons for the User Portal along with the redesign work we will be doing for 4.0. So it is a small piece that will fall under the 4.0 changes that will be made.

Comment 4 Michal Skrivanek 2015-06-05 13:19:37 UTC
still want to consider this "soon"

Comment 5 Michal Skrivanek 2016-02-12 10:09:44 UTC
will comment #3 happen in 4.0 timeframe?

Comment 6 Oved Ourfali 2016-02-12 12:56:38 UTC
You can talk to Eldan and see whether he can provide new icons.

Comment 7 Yaniv Kaul 2017-11-16 13:12:33 UTC
Michal - I think we've refreshed the icons in 4.2?

Comment 8 Michal Skrivanek 2017-11-16 13:27:30 UTC
yep

Comment 9 Pavol Brilla 2017-11-21 13:22:11 UTC
Verified on:4.2.0-0.0.master.20171114111003.git7aa1b91.el7.centos

Guest OS have icon according to family, RHEL is following Branding Guide

Comment 10 Sandro Bonazzola 2017-12-20 10:56:22 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.