Bug 112876 - up2date miss-complains about depencies
up2date miss-complains about depencies
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 03:52 EST by Stian Skjelstad
Modified: 2007-04-18 13:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 17:58:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stian Skjelstad 2004-01-05 03:52:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
First some cut'n paste:

[root@dhcppc8 candela.no]# up2date -u up2date

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################

Fetching rpm headers...
########################################
All packages are currently up to date
[root@dhcppc8 candela.no]# rpm -q up2date
up2date-3.1.23.2-1
[root@dhcppc8 candela.no]# up2date -u

Fetching package list for channel: redhat-linux-i386-9...
########################################

Fetching Obsoletes list for channel: redhat-linux-i386-9...
########################################

Fetching rpm headers...
########################################

Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
spamassassin-tools  2.61-1               requires
perl(Mail::SpamAssassin::ArchiveIterator)
spamassassin-tools-2.61-1                requires
perl-Mail-SpamAssassin = 2.61-1

[root@dhcppc8 candela.no]# rpm -qa|grep -i spamassassin
spamassassin-tools-2.61-1
spamassassin-2.61-1
perl-Mail-SpamAssassin-2.61-1
[root@dhcppc8 candela.no]# rpmquery -q perl-Mail-SpamAssassin-2.61-1
--provides
config(perl-Mail-SpamAssassin) = 2.61-1
perl(Mail::SpamAssassin) = 2.61
perl(Mail::SpamAssassin::ArchiveIterator)  
perl(Mail::SpamAssassin::AuditMessage)  
perl(Mail::SpamAssassin::AutoWhitelist)  
perl(Mail::SpamAssassin::Bayes)  
perl(Mail::SpamAssassin::BayesStore)  
perl(Mail::SpamAssassin::CmdLearn)  
perl(Mail::SpamAssassin::Conf)  
perl(Mail::SpamAssassin::ConfSourceSQL)  
perl(Mail::SpamAssassin::DBBasedAddrList)  
perl(Mail::SpamAssassin::Dns)  
perl(Mail::SpamAssassin::EncappedMIME)  
perl(Mail::SpamAssassin::EncappedMessage)  
perl(Mail::SpamAssassin::EvalTests)  
perl(Mail::SpamAssassin::HTML)  
perl(Mail::SpamAssassin::Locales)  
perl(Mail::SpamAssassin::Locker)  
perl(Mail::SpamAssassin::MailingList)  
perl(Mail::SpamAssassin::Message)  
perl(Mail::SpamAssassin::NetSet)  
perl(Mail::SpamAssassin::NoMailAudit)  
perl(Mail::SpamAssassin::PerMsgLearner)  
perl(Mail::SpamAssassin::PerMsgStatus)  
perl(Mail::SpamAssassin::PersistentAddrList)  
perl(Mail::SpamAssassin::Received)  
perl(Mail::SpamAssassin::Replier)  
perl(Mail::SpamAssassin::Reporter)  
perl(Mail::SpamAssassin::SHA1)  
perl(Mail::SpamAssassin::TextCat)  
perl(Mail::SpamAssassin::UnixLocker)  
perl(Mail::SpamAssassin::Util)  
perl(Mail::SpamAssassin::Win32Locker)  
perl-Mail-SpamAssassin = 2.61-1
[root@dhcppc8 candela.no]# rpm -V spamassassin-tools-2.61-1
[root@dhcppc8 candela.no]# 


As you can see, up2date -u fails, with a dependency problem and
refuses then to do the upgrade. But when I check by hand, all
dependencies are present, and verifying that package does not fail. It
is just up2date that has problems.

These kinds of problem kan be a problem for servers that just has
their crontab or up2date running other methods and rely on them being
up to date with fixes.

Version-Release number of selected component (if applicable):
up2date-3.1.23.2-1

How reproducible:
Always

Steps to Reproduce:
1. Compile the srpm of the spamassassin version 2.60-1 og 2.61-1
available on their homepage 
2. Install the resulting 3 rpms files you get
3. up2date -u
    

Actual Results:  See description

Expected Results:  See description

Additional info:

See description

Note You need to log in before you can comment on or make changes to this bug.