Bug 112877 - Replace ugly Baekmuk fonts with Un-series truetype fonts (Korean)
Replace ugly Baekmuk fonts with Un-series truetype fonts (Korean)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: fonts-korean (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 04:00 EST by Jungshik Shin
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 01:24:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jungshik Shin 2004-01-05 04:00:55 EST
Description of problem:

Un-series Korean truetype fonts (of a far higher quality than Baekmuk
fonts) are not included in ttfonts-ko. 

I announced the availability of Un-series truetype fonts at gtk-i18n
and linux-utf8 list hoping that somebody at RedHat would read it and
add Un-series Korean truetype fonts to next RedHat
distributions/Fedora. Unfortunately, Fedora Core1 didn't come with
them so that I had to install them all.

Un-series Korean fonts are available at 

http://i18nl10n.com/korean/unbatang.ttf (UnBatang : opentype font with 
    GSUB tables for Korean Hangul Jamo rendering)
http://chem.skku.ac.kr/~wkpark/project/font/UnFonts (the rest of
Un-series fonts. UnBatang should NOT be picked up from here).

Advantages over Baekmuk fonts (included in most Linux distributions) are:

 - they come in 7 families        : UnBatang(serif), UnDotum(sans-serif),
                                    UnGungseo(cursive, brush-stroke),
                                    UnPilgi (script), UnShinmun,
                                    UnYetgul (a bit like 'Frankfurt' ? and
                                              old Korean printing style),
                                    UnBom, UnGraphic

 - wider character repertoire : covers the fullset of Latin-1 as well
                                as the full set of
                                precomposed Hangul syllables, and
                                Chinese characters in KS X 1001

 - three of them come in bold as well as in regular
   (no need to tinker with 'artificial bolding')

 - one of them (UnBatangOdal) has GSUB tables for pre-1933 orthography
   Korean text rendering with Korean letters (Hangul Jamos).


These fonts were originally made for Korean LaTex/TeX by UN Koaunghi
as a set of type1 postscript fonts. He painstakingly scanned,
converted to outlines and hand-tune glyphs. Last year, PARK Won-kyu
converted them all to truetype fonts. To one of them (UnBatang), he
and I added GSUB tables for Korean Hangul Jamo renerings. UN Koanunghi
released original fonts under GPL and PARK Wonkyu's truetype fonts are
also GPL'd. 

It'd be great if Un-series fonts are included in next release of Fedora.
Comment 1 Jungshik Shin 2004-01-05 04:10:09 EST
UnBatang is available at the following URL (the one given above should
be ignored)

 http://i18nl10n.com/korean/UnBatang.ttf
Comment 2 Jungshik Shin 2004-08-10 03:15:13 EDT
Un-series fonts (1.0) were released a couple of days ago. They're
available at 

http://kldp.net/projects/unfonts 

SuSe linux 9.1 has them and it'd be nice to have them included in FC 3. 
Comment 3 David Joo 2004-08-13 00:08:58 EDT
Hi,

I have been testing fonts for quite sometime now.
Also, I am considering adding another fonts that were posted on
linux-sarang.net.

Have you seen that one as well?

Currently this is going through number of engineers to be finalised,
once it is done, it will be added.

Regards,
David Sungmin Joo
Comment 4 Jungshik Shin 2004-08-13 00:25:46 EDT
> I am considering adding another fonts that were posted on
> linux-sarang.net.

The more the better.... However, you MUST NOT add 'hmfs'. It has
Hangul Jamos at US-ASCII code points, which is a 'horrible' hack.
Comment 5 Owen Taylor 2004-09-06 09:20:43 EDT
If we add new fonts, we need to think about whether we are going 
to remove some or all old fonts ... having 10 different families of
Korean fonts doesn't make sense to me.

Generally, what should be in Fedora Core should be fonts that:

 - Are correct (have the right glyphs at the right codepoints, the
   necessary extra tables)
 - Render well
 - Serve distinct purposes

Having two different 'Dotum' fonts is just going to confuse the
user and clutter the menu.

In general, as well, Fedora Core shouldn't contain decorative
fonts, just text fonts. (An example of a decorative fonts would
be one of those latin fonts that looks like it is made up of
wooden logs nailed together.)
Comment 7 Jungshik Shin 2004-09-07 11:31:49 EDT
I don't think having two different 'Dotum' fonts is that much
confusing. Anyway, if you think only one of them has to be included,
the answer is clear. Baekmuk fonts have to go and Un-series fonts
should take their places. In addition, /etc/fonts/fonts.conf has to be
adjusted accordingly. 
Comment 8 Rahul Sundaram 2005-09-04 23:24:35 EDT

Might consider packaging them for Fedora Extras

http://fedoraproject.org/wiki/Extras

Comment 9 Jungshik Shin 2006-07-11 22:26:22 EDT
I found that FC5 has a new set of Japanese fonts, but it still has ugly Baekmuk
fonts. 

(In reply to comment #8)
> 
> Might consider packaging them for Fedora Extras
> 
> http://fedoraproject.org/wiki/Extras

Un-fonts are not something extra, but are an essential part for Korean users.

Baekmuk fonts must be removed immediately (because they're certainly inferior to
Un-fonts in terms of criteria outlined in comment #5) if you're  worried about
having two sets of Korean TTFs. In their place, Un-fonts should go in. 

The first thing new Korean FC users need to do is to install Un-fonts and adjust
fontconfig configuration files accordingly.

Comment 10 Leon Ho 2006-09-06 00:48:53 EDT
(bug was outside the radar, putting it back into the radar)

Since FC6 is freezing, we should use the normal channel to go through the new
package through FE so it can be in the next FC release.

However we still couldn't get enough information to clear legal and origin of
the font glyph to be included in Fedora. 

Jungshik, for clearing the legal background of the fonts, could you help us
getting an ownership statement, mainly stating:
   - From the designers of all glyphs within the font and ownership of them
   - the origin of the glyph design or what fonts/glyphs is it inspired from.
   - the owner(s) have granted the license of GPL.

There will be some copyright issue if the inspiration is a copyrighted material
and the original copyright holders did not grant the usage of the designs.

Thanks.
Comment 11 Jungshik Shin 2006-09-07 01:35:09 EDT
My effort to  contact UN KoaungHi, who scanned old (reportedly tens of years
old) documents/books, extracted glyphs and convert them to type 1 fonts, has not
been successful. 
Comment 12 Caius Chance 2007-03-12 01:24:41 EDT
I am closing this bug because there was not able to contact the owner(s) who
have granted the license of GPL.

Please kindly create another new bug if there is any other solutions for
replacing the current Korean fonts by higher quality ones.
Comment 13 Jens Petersen 2007-03-12 21:58:31 EDT
I suggest submitting a package of the Un-series fonts for review for inclusion
in Fedora as a separate package.  In fact fonts-korean may not be the optimal
vehicle for getting the right Hangul fonts into Fedora as we already see.

See http://fedoraproject.org/wiki/PackageReviewProcess for more details.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.