Bug 1128786 - pg_timeout none results in error messages DM message failed [set_pg_timeout 0]
Summary: pg_timeout none results in error messages DM message failed [set_pg_timeout 0]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks: 1075802 1159933
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:32 UTC by Marko Karg
Modified: 2018-12-06 17:42 UTC (History)
11 users (show)

Fixed In Version: device-mapper-multipath-0.4.9-82.el6
Doc Type: Bug Fix
Doc Text:
Cause: the pg_timeout feature is not supported my the device mapper multipath target, and so setting it causes an error. However device-mapper-multipath allows users to set it. Consequence: If users set pg_timeout, they receive error messages Fix: multipath now ignores the pg_timeout option Result: users are not able to set the pg_timeout feature, and will not receive error messages from device-mapper.
Clone Of:
Environment:
Red Hat Enterprise Linux 6.5
Last Closed: 2015-07-22 07:26:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1391 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2015-07-20 18:07:34 UTC
Red Hat Knowledge Base (Solution) 1159753 None None None Never

Description Marko Karg 2014-08-11 14:32:10 UTC
Description of problem:

If /etc/multipath.conf contains a line 

        pg_timeout none

then messages like these

   Aug  8 06:21:30 infl0242 multipathd: DM message failed [set_pg_timeout 0]

show up during boot or multipathd restarts

Version-Release number of selected component (if applicable):

device-mapper-multipath-0.4.9-72.el6_5.3.x86_64             
device-mapper-multipath-libs-0.4.9-72.el6_5.3.x86_64

How reproducible:

always

Steps to Reproduce:
1. update device-mapper-multipath to the versions mentioned above
2. add pg_timeout none to the defaults section of the multipath.conf
3. reboot / restart multipathd

Actual results:

multipathd: DM message failed [set_pg_timeout 0]

is shown

Expected results:

no (error) message

Additional info:

Comment 2 Ben Marzinski 2014-08-11 22:27:20 UTC
Yeah.  The kernel doesn't support pg_timeout (it never has. The patch wasn't accepted).  So, setting it to any valid value (including "none"), will cause it to send a message that the kernel doesn't accept.

I assume that the issue is

# multipathd show config

displays

pg_timeout none

I can fix this so that multipathd will accept any value for pg_timeout, and not do anything with it, and not display that value when you run the "show config" command

Comment 6 Ben Marzinski 2015-01-07 03:48:30 UTC
Fixed as per Comment 2

Comment 10 errata-xmlrpc 2015-07-22 07:26:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1391.html


Note You need to log in before you can comment on or make changes to this bug.