Bug 112879 - Mozilla should be compiled with freetype enabled for a better printint
Mozilla should be compiled with freetype enabled for a better printint
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 04:20 EST by Jungshik Shin
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 13:39:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jungshik Shin 2004-01-05 04:20:34 EST
Mozilla included in Fedora Core1 was compiled with freetype disabled.
As far as the screen rendering is concerned, freetype is redundant
because Xft offers a far better screen rendering result. However, when
it comes to print-out, freetype is a lot better than the default
postscript printing. Especially for non-Western-European users, the
default postscript printing of Mozilla is almost useless because in
the print-out only a single font can be used no matter how many
different fonts and font styles (bold, italic, etc) may be used in the
screen rendering. 

Freetype printing offers a much better alternative. See my posting to
mozillazine forum :

http://forums.mozillazine.org/viewtopic.php?t=24550&postdays=0&postorder=asc&start=30

See also

http://www.mozilla.org/releases/mozilla1.6b/known-issues-int.html#printing

http://bugzilla.mozilla.org/show_bug.cgi?id=219060
Comment 1 Christopher Blizzard 2004-02-12 13:39:40 EST
Nope, I'm not going to enable the freetype code in our builds.
Comment 2 Joachim Frieben 2006-02-20 15:33:06 EST
How about reconsidering enabling "FreeType2" in the "mozilla" builds?
Fedora browsers still only offer plain PS fonmt printing. "Xprint" has
also been discarded by the Red Hat developers. This makes life sort of
difficult. In the past, I built my own "xorg-x11-Xprint" packages, but
now that e.g. "epiphany" does not even use the "mozilla" printing backend
anymore, one hardly knows ewhat to do.

When "Xprint" support got declined, Red Hat developers stressed, that they
were pursuing an alternative solution. This must have been about 2 years
ago :(
Comment 3 Jungshik Shin 2006-02-20 15:55:50 EST
There's absolutely no need to enable freetype for a better printing quality
because I greatly improved Mozilla's PS printing. There's little need for
Xprint. I can't imagine any text that can be rendered better with Xprint than
with the current Mozilla printing engine. 

See 
https://bugzilla.mozilla.org/show_bug.cgi?id=234182
Comment 4 Joachim Frieben 2006-02-21 02:29:56 EST
I want to be able to print web pages using "Truetype" fonts as they are
rendered on-screen. In the case of "mozilla", this works for me when "xprint"
is enabled, and an "xprint" server is installed and running as well as the
required "TrueType" fonts. An "epiphany" developer suggested to rebuild
"mozilla" with "--enable-freetype2" to obtain "TrueType" fonts printing for
newer releases of "epiphany" that rely on "libgnomeprint[ui]". Right now,
"epiphany" (based upon "mozilla") falls back to plain "PostScript" fonts#
which is undesirable.
Comment 5 Jungshik Shin 2006-02-21 09:02:49 EST
I don't what's going on with Epiphani. Anyway, they're downright wrong. There's
absolutely no need to enable freetype2 to print with **truetype** fonts. PLEASE,
read what's done at mozilla bug 234182 !!! There WAS a reason for me to burn a
lot of candles 'killing' quite a lot of trees and printer ink. 

The print quality of firefox 1.5.x with the PS engine that *embeds* truetype
glyphs (after converting them to PS type 1 outlines) is a lot better (in terms
of WYSWYG and other aspects) than the print quality obtained with Xprint that
relies on 20-year old XLFD. 
Comment 6 Joachim Frieben 2006-02-21 12:17:03 EST
Thanks for your comment. To be honest, I do not have "firefox" installed
on my system. On "Fedora Core", "epiphany" is built against plain "mozilla"
and requires this package to be installed. For your information, here my
bug report for "epiphany":

  http://bugzilla.gnome.org/show_bug.cgi?id=323892
Comment 7 Christian Persch (GNOME) 2006-02-21 14:11:06 EST
The patch from mozilla bug https://bugzilla.mozilla.org/show_bug.cgi?id=234182
is not present in mozilla 1.7 which is what FC *still* inflicts on their gecko
embedders.
Comment 8 Jungshik Shin 2006-02-22 03:14:48 EST
(In reply to comment #7)

> is not present in mozilla 1.7 which is what FC *still* inflicts on their gecko
> embedders.

Given the above, Joachim, what you can do is to file a new FC bug for upgrading
to Gecko 1.8 which is used by Firefox 1.5/Seamonkey 1.0/Thunderbird 1.5


Note You need to log in before you can comment on or make changes to this bug.