Bug 1128798 - Error printing: Operation not supported
Summary: Error printing: Operation not supported
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gtk2
Version: 6.6
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:49 UTC by Jiri Koten
Modified: 2014-10-14 07:41 UTC (History)
5 users (show)

Fixed In Version: gtk2-2.24.23-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 07:41:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1554 normal SHIPPED_LIVE gtk2, gdk-pixbuf2, librsvg2, and libwmf bug fix and enhancement update 2014-10-14 01:27:57 UTC

Description Jiri Koten 2014-08-11 14:49:17 UTC
Description of problem:
When I print a Contact or Calendar and use the Print to File it fails with the dialog: Error printing: Operation not supported.

When I try it for the second time the fields Name: and Save in Folder are empty. After filling them out I'm able to proceed and get the pdf file.   

Version-Release number of selected component (if applicable):
evolution-2.32.3-33.el6

How reproducible:
100%

Steps to Reproduce:
1. Select a Contact
2. Right Click > Print
3. Choose the Print to File
4. Use the defaults settings and Print

Actual results:
Error printing

Expected results:
You get the pdf file with the contact

Additional info:

Comment 1 Jiri Koten 2014-08-11 14:56:49 UTC
Console output:

(evolution:22733): e-utils-WARNING **: Not a valid page setup file

Comment 3 Matthew Barnes 2014-08-21 23:39:15 UTC
(In reply to Jiri Koten from comment #0)
> Description of problem:
> When I print a Contact or Calendar and use the Print to File it fails with
> the dialog: Error printing: Operation not supported.

"Operation not supported" typically indicates some missing GVFS component.


> When I try it for the second time the fields Name: and Save in Folder are
> empty. After filling them out I'm able to proceed and get the pdf file.   

This is describing the GtkPrintUnixDialog widget in gtk2.


Not an Evolution bug, but I'll try investigating this a bit more before reassigning.

Comment 4 Matthew Barnes 2014-08-22 00:04:47 UTC
Printing to a file is implemented as a backend module within gtk2.

I suspect the "Operation not supported" call is the result of passing a bad URI to g_file_replace() in this function:

https://git.gnome.org/browse/gtk+/tree/modules/printbackends/file/gtkprintbackendfile.c?h=gtk-2-24#n436

It would be instructive if you could run Evolution under gdb and set a breakpoint on that function, execute a "Print to File" to trigger a breakpoint, and step through the function far enough to examine the value of the 'uri' variable.

I tried to reproduce the failure but was unable; printing to a file worked correctly for me on the first try.

Reassigning to gtk2, although it may just be a user environment issue.

Comment 5 Jiri Koten 2014-08-22 12:50:17 UTC
Well, it looks like the uri is "empty".
(gchar *) 0x2f37150 "" vs. (gchar *) 0x3158d30 "file:///tmp/test".

This happens when I start Evolution, in gui it shows test as filename and tmp as dir., but it fails to print (because the uri is actually "empty"). When I open the print dialog again the fields are empty and filling them out fix the issue until the next start.

So it seems the default values used from previous run are lost or not propagated even though they are shown in the gui.

Comment 6 Marek Kašík 2014-08-22 13:19:11 UTC
Thank you for CCing me. This the same problem as the one we've recently fixed in RHEL 7 in the bug #1109100. I've tested the same patch here and it fixes the problem.

Comment 9 errata-xmlrpc 2014-10-14 07:41:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1554.html


Note You need to log in before you can comment on or make changes to this bug.