Bug 11288 - Upgrade is not very Upgracious!
Upgrade is not very Upgracious!
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-07 23:40 EDT by Stuart Blake Tener
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-06-09 18:26:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stuart Blake Tener 2000-05-07 23:40:27 EDT
Let us begin by stating the Winbloze 2000 Server is installed on one
partition, and RH 6.1 on the other.

When trying to do a "linux updates text" install using the latest boot
disk, and latest anaconda disk, the following error occurs:

Output from anaconda:

Exception occurred:

Traceback (innermost last)
File "/usr/bin/anaconda", line 342, in? intf.run(todo, test=test)
File "/usr/lib/anaconda/text.py", line 1163, in run rc=apply (Step[1](),
(dir,) + Step[2])

File "/usr/lib/anaconda/text.py", line 317, in __call__
todo.UpgradeFindPackages (root)

File "/tmp/updates/todo.py", line 719, in UpgradeFindPackages
self.fstab.mountfilesystems (self.instpath)

File "/usr/lib/anaconda/fstab.py", line 464, in mountfilesystem raise
SystemError (errno, msg)

SystemError (15, 'block device required')

1) It was during an upgrade
2) Pentium 200 MHz non mmx, 96MB RAM, 10GB HD, Acer 2x2x6 CD/RW Drive
3) Cheapbytes copy of the image downloaded from your ftp site (image was
compared, and is an accurate and correct and true copy of your iso)

Far be it from me to make any intelligent comments, but, may I suggest a
few additional features I would like to see in your next ISO release:

1) Anaconda has broken and required update disks in the past two releases;
why not include on the CDROM a way to boot up which will allow for an
anaconda update disk to be provided. This way we need only futz around with
one update disk, the anaconda disk. Dont tell me this is impossible, we all
know it is. There ought be no need to download a new "boot disk" when an
update to anaconda is needed.

Why does anaconda keep breaking? Let us relate some Jewish Mysticism here
Anaconda is a type of snake, and traditionally a snake is the most negative
animal according to Jewish beleive. Predicated upon the fact, it was the
very snake which enticed Eve to eat of the tree of knowledge. Further the
word snake (in Hebrew, nehash), has a numerical value of 365. Exactly the
number of negative commandments in the olde testament. The word nehash (3
hebrew letters) can also be related via numerical analysis to the word for
death (3 letters also, mavet). Need I continue?

On a more non mystical level, an Anaconda is exactly the type of snake
which "constricts" at night it's prey. This is not the type of imagery I
would wish to envision relative to a server I am installing Linux on.

Perhaps you ought rename the anaconda program to something else.
Comment 1 Stuart Blake Tener 2000-05-28 12:04:59 EDT
This bug apparently has to do with Lilo not being able to work when installing
Linux on the part of a drive which exceeds the 1024 cylinder boundry. I moved
where I am installing Linux, and it seems to be okay now.

Why does lilo have such a limitation? We have the source, and other OSes dont
have such limits. If M$ OSes can work anywhere on the HD, why doesnt Linux?

By the way, I still think we ought to change the name of anaconda.
Comment 2 Michael Fulbright 2000-06-09 18:26:10 EDT
The latest version of LILO can support > 1024 cylinder booting on supported
hardware, and we are considering its use in future releases.

Note You need to log in before you can comment on or make changes to this bug.