Bug 1128800 - [RFE] Local domain with low available disk space leads to a very slow host,errors on engine logs and possibly host collapse
Summary: [RFE] Local domain with low available disk space leads to a very slow host,er...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RFEs
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On: 679070
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 14:50 UTC by Ori Gofen
Modified: 2017-01-31 13:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 13:10:24 UTC
oVirt Team: Storage
ylavi: ovirt-future?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)
vdsm+engine logs (671.94 KB, application/gzip)
2014-08-11 14:50 UTC, Ori Gofen
no flags Details

Description Ori Gofen 2014-08-11 14:50:26 UTC
Created attachment 925807 [details]
vdsm+engine logs

Description of problem:

a Packed local domain shouldn't be aloud on any case,it damages host's Performance and can lead to collapsion. 

After filling the local domain to almost zero free space,host became very slow.

message on UI:
"Host vdsb has less than 500 MB of free space"

Version-Release number of selected component (if applicable):
rc1

How reproducible:
100%

Steps to Reproduce:
1.create a local domain and fill it with disks

Actual results:
Engine throws:

2014-08-11 16:51:01,162 ERROR [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-16) Correlation ID: null, Call Stack: null, Custom Event   ID: -1, Message: Critical, Low disk space. Host vdsb has less than 500 MB of free space left on: /var/log/core, /tmp, /var/log, /var/run/vdsm/.

host become's slow.

Expected results:
local domain should have a different space policy from regular sd due to the sensitivity of its location

Additional info:

Comment 1 Ori Gofen 2014-08-13 13:04:24 UTC
we can really use a threshold flag which will also block with CDA, operations who violates the space policy,not only warn the user.

for example when RPE,BZ #679070 ,will be operational (I'll refer to #679070 RFE as 'FreeSpaceCriticalLowOnDomainInGB',and to simplify,this feature will be 'FreeSpaceCriticalLowOnDomainFLAG') a user should be able to set a related flag to 'permissive' ,'enforce' . permissive will warn the user,and enforce will block with CNA the operations which violate the free space policy.

Naturally,the configuration of a local domain will be by default:

FreeSpaceCriticalLowOnDomainInGB=SOME_THRESHOLD
FreeSpaceCriticalLowOnDomainFLAG='enforce'

FreeSpaceCriticalLowOnDomainFLAG -> could not be changed
FreeSpaceCriticalLowOnDomainInGB -> could not be set to integer below SOME_THRESHOLD

Comment 3 Allon Mureinik 2017-01-31 13:10:24 UTC
The free space threshold can be configured per domain, we won't do anything out of the box here.


Note You need to log in before you can comment on or make changes to this bug.