Bug 1128807 - Second suspend of a vm doesn't work
Summary: Second suspend of a vm doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Ravi Nori
QA Contact: Antonin Pagac
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 15:11 UTC by Vered Volansky
Modified: 2016-05-05 04:38 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0_rc1.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:34:35 UTC
oVirt Team: Infra


Attachments (Terms of Use)
engine.log (2.24 MB, text/x-log)
2014-08-11 15:11 UTC, Vered Volansky
no flags Details
vdsm.log (13.04 MB, text/x-log)
2014-08-11 15:26 UTC, Vered Volansky
no flags Details
screenshot of user error message (1.94 MB, image/png)
2014-08-11 15:40 UTC, Vered Volansky
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31525 master MERGED engine : Second suspend of a vm doesn't work Never
oVirt gerrit 31585 ovirt-engine-3.5 MERGED engine : Second suspend of a vm doesn't work Never

Description Vered Volansky 2014-08-11 15:11:13 UTC
Created attachment 925811 [details]
engine.log

Description of problem:
Second suspend of a vm doesn't work

Version-Release number of selected component (if applicable):
u/s engine eda3e46222d597b0844d7bba5b809282bda010d9 .
vdsm nightly - vdsm-4.16.1-0.gita4d9abf.fc20.x86_64

Steps to Reproduce:
1. Create a new VM and run it (without actual OS installation, default settings apart from nic - ovirtmgmt).
2. Hibernate (suspend).
3. Run.
4. Hibernate.

Actual results:
NPE, bad user message. Will logs and screenshot of the error message.

Expected results:
Hibernate.

Logs should contain vm creation - named 'vm', as well as 'vm111' creation.

Comment 1 Vered Volansky 2014-08-11 15:26:49 UTC
Created attachment 925816 [details]
vdsm.log

Comment 2 Vered Volansky 2014-08-11 15:28:42 UTC
This happened to me on a virt flow, but looks like infra NPE:
2014-08-11 17:49:18,020 ERROR [org.ovirt.engine.core.bll.HibernateVmCommand] (http--0.0.0.0-8080-2) [2d17e3c8] Error during CanDoActionFailure.: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.tasks.AsyncTaskManager.isCurrentTaskLookedFor(AsyncTaskManager.java:378) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.AsyncTaskManager.entityHasTasks(AsyncTaskManager.java:783) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.TaskManagerUtil.entityHasTasks(TaskManagerUtil.java:50) [bll.jar:]
	at org.ovirt.engine.core.bll.HibernateVmCommand.canDoAction(HibernateVmCommand.java:255) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.internalCanDoAction(CommandBase.java:746) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.canDoActionOnly(CommandBase.java:321) [bll.jar:]
	at org.ovirt.engine.core.bll.MultipleActionsRunner.execute(MultipleActionsRunner.java:78) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runMultipleActionsImpl(Backend.java:547) [bll.jar:]
	at org.ovirt.engine.core.bll.Backend.runMultipleActions(Backend.java:517) [bll.jar:]

Comment 3 Vered Volansky 2014-08-11 15:40:29 UTC
Created attachment 925819 [details]
screenshot of user error message

Error while executing action:

vm:

    General command validation failure.

Comment 4 Michal Skrivanek 2014-08-12 06:52:54 UTC
smells like coco. Oved, can you please check out?

Comment 5 Antonin Pagac 2014-09-04 10:37:42 UTC
Verified in: oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6

Multiple suspend works also with vms with/without disks and systems.

Comment 6 Sandro Bonazzola 2014-10-17 12:34:35 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.