Bug 1128808 - Distributed iterator throws ClassCastException when loader contains values that pass filter
Summary: Distributed iterator throws ClassCastException when loader contains values th...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER1
: 6.3.1,6.4.0
Assignee: Tristan Tarrant
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 15:13 UTC by William Burns
Modified: 2015-01-26 14:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-26 14:05:54 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-4376 Major Resolved AdvancedCache.filterEntries(...) does not respect configured cache flags 2016-04-07 03:22:16 UTC
JBoss Issue Tracker ISPN-4583 Major Resolved Distributed iterator throws ClassCastException when loader contains values that pass filter 2016-04-07 03:22:16 UTC

Description William Burns 2014-08-11 15:13:25 UTC
Description of problem:

Entry iterator (distributed) doesn't work properly with a loader with values.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 William Burns 2014-08-11 15:14:36 UTC
Also added additional JIRA that was fixed at the same time as this one since they were interrelated.

Comment 3 Adrian Nistor 2014-08-12 15:18:05 UTC
Integrated in jdg-6.3.x and jdg-6.4.x.

Comment 4 Alan Field 2014-08-21 12:37:06 UTC
Verified that ISPN-4583 is no longer reproducible with JDG 6.3.1 ER1. Still need to verify the ISPN-4376 part of this change.

Comment 5 Alan Field 2014-08-25 09:24:54 UTC
Talked to Will Burns about verifying ISPN-4376. The only supported flags are SKIP_CACHE_LOAD and CACHE_MODE_LOCAL. A distributed test existed to verify these flags, so I added tests for replicated, invalidation, and local modes. All tests passed with JDG 6.3.1 ER1. Sent PRs to Infinispan master, JDG 6.3, and 6.4 branches.


Note You need to log in before you can comment on or make changes to this bug.