Bug 1128857 - [RFE] NGINX solution for External LB Architecture
Summary: [RFE] NGINX solution for External LB Architecture
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Mike Barrett
QA Contact:
URL:
Whiteboard:
Depends On: 1128851
Blocks: 1128853 1128854 1128856 1159393 1163499
TreeView+ depends on / blocked
 
Reported: 2014-08-11 16:07 UTC by Eric Rich
Modified: 2018-12-09 18:20 UTC (History)
13 users (show)

Fixed In Version: rubygem-openshift-origin-routing-daemon-0.17.1.2-1.el6op.noarch.rpm, rubygem-openshift-origin-routing-activemq-0.6.1.1-1.el6op
Doc Type: Bug Fix
Doc Text:
Clone Of: 1128851
Environment:
Last Closed: 2014-12-10 13:25:39 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1978 normal SHIPPED_LIVE Red Hat OpenShift Enterprise 2.2.2 routing daemon bug fix update 2014-12-10 18:24:14 UTC

Description Eric Rich 2014-08-11 16:07:29 UTC
+++ This bug was initially created as a clone of Bug #1128851 +++

Description of problem:

Currently the External Load Balancer Architecture is plug-able and allows you to choose a load balancer of your choice. 

However Red Hat makes not recommendation / does not provide examples with any of its existing load balancing solutions. 

Additional info:

An example using NGINX should be provided to show customers what a listener / LB solution looks like. 

https://access.redhat.com/solutions/32303

Comment 9 chris alfonso 2014-10-22 15:47:01 UTC
source is merged and tagged, waiting for next puddle build.

Comment 30 chris alfonso 2014-11-17 20:27:51 UTC
The root cause of the failover we are seeing is due to the ruby Stomp::Connection object being cached/reused, which is fine and actually preferred in most scenarios. However, for the failover scenario the stomp client assumes the connection for the first message it's sending after a failover is healthy and so the message gets lost. A patch to reinitialize the ruby stomp connection will be submitted shortly.

Comment 31 Johnny Liu 2014-11-24 06:30:11 UTC
Re-test this bug with 2.2/2014-11-20.1, FAIL.

Firstly, in the latest puddle(2.2/2014-11-20.1), the latest rubygem-openshift-origin-routing-activemq-0.6.1.1-1.el6op is not included into this puddle.

Secondly, for rubygem-openshift-origin-routing-daemon-0.17.1.2-1.el6op, it introduced some new bugs, pls refer to the following bugs for more details, and these bugs are blocking this bug's verification.
https://bugzilla.redhat.com/show_bug.cgi?id=1166600
https://bugzilla.redhat.com/show_bug.cgi?id=1166593

Comment 32 Brenton Leanhardt 2014-11-24 13:49:10 UTC
Sorry, somehow I must have failed to attach the build.  It will make it into today's puddle.

Comment 33 Johnny Liu 2014-11-25 10:03:49 UTC
Re-test failover with latest puddle 2.2/2014-11-24.3, it works well when at least one running activemq is existing, but once there is no any running activemq, routing daemon will not reconnect even if activemq come back, pls refer to https://bugzilla.redhat.com/show_bug.cgi?id=1167707 for more detail, so I think the new bug also is blocking this bug's verification.

Comment 34 Johnny Liu 2014-11-28 13:24:05 UTC
All the blocked bug is fixed, so I think this bug could be moved to ON_QA now.

Comment 35 Johnny Liu 2014-12-01 10:43:54 UTC
After BZ#1169324 is fixed, will verify this bug.

Comment 38 Johnny Liu 2014-12-03 06:37:17 UTC
All the blocking bug is fixed in rubygem-openshift-origin-routing-daemon-0.20.2.5-1.el6op.noarch, so move this bug to verified status, but still need note that BZ#1168994 maybe bring some troubles.

Comment 40 errata-xmlrpc 2014-12-10 13:25:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1978.html


Note You need to log in before you can comment on or make changes to this bug.