Bug 1128862 - Intel E5620 Westmere not recognized as such
Summary: Intel E5620 Westmere not recognized as such
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel
Version: 7.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: pre-dev-freeze
: ---
Assignee: Peter Martuccelli
QA Contact: Evan McNabb
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 16:23 UTC by Netbulae
Modified: 2014-08-14 17:34 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 22:22:36 UTC


Attachments (Terms of Use)
dmesg (82.69 KB, text/plain)
2014-08-13 13:09 UTC, Netbulae
no flags Details

Description Netbulae 2014-08-11 16:23:57 UTC
Description of problem:

I get the following error:

WARN  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (DefaultQuartzScheduler_Worker-50) [531a532e] Correlation ID: 2e9f33ba, Call Stack: null, Custom Event ID: -1, Message: Host vh03en01.netbulae.mgmt moved to Non-Operational state as host does not meet the cluster's minimum CPU level. Missing CPU features : aes, model_Westmere


It is listed as Westmere though

https://en.wikipedia.org/wiki/Intel_Westmere

But there is no "aes" in this CPU

When I set it to Nehalem, the host is up.

cat /proc/cpuinfo:

processor	: 15
vendor_id	: GenuineIntel
cpu family	: 6
model		: 44
model name	: Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz
stepping	: 2
microcode	: 0x14
cpu MHz		: 2401.000
cache size	: 12288 KB
physical id	: 1
siblings	: 8
core id		: 10
cpu cores	: 4
apicid		: 53
initial apicid	: 53
fpu		: yes
fpu_exception	: yes
cpuid level	: 11
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 popcnt lahf_lm ida arat epb dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 4799.88
clflush size	: 64
cache_alignment	: 64
address sizes	: 40 bits physical, 48 bits virtual

Comment 1 Dan Kenigsberg 2014-08-13 12:36:39 UTC
According to /usr/share/libvirt/cpu_map.xml

    <model name='Westmere'>
      <model name='Nehalem'/>
      <feature name='aes'/>
    </model>

as well as http://ark.intel.com/products/47925/Intel-Xeon-Processor-E5620-%2812M-Cache-2_40-GHz-5_86-GTs-Intel-QPI%29 Westmere should support the aes instruction.

The fact that aes is not reported in /proc/cpuinfo, suggests a bug in the kernel or in the cpu itself.

What is your kernel version?
Could you attach the output of your dmesg?

Comment 2 Netbulae 2014-08-13 13:09:49 UTC
Created attachment 926415 [details]
dmesg

Kernel: 3.10.0-123.6.3.el7.x86_64

from dmesg:

[    0.084946] smpboot: CPU0: Intel(R) Xeon(R) CPU           E5620  @ 2.40GHz (fam: 06, model: 2c, stepping: 02)
[    0.186672] Performance Events: PEBS fmt1+, 16-deep LBR, Westmere events, Intel PMU driver.

Comment 3 Netbulae 2014-08-13 13:35:49 UTC
It is configured as module (AES_NI_INTEL):

cat /boot/config-3.10.0-123.6.3.el7.x86_64 |grep AES

CONFIG_SND_MAESTRO3=m
CONFIG_SND_MAESTRO3_INPUT=y
CONFIG_CRYPTO_AES=y
CONFIG_CRYPTO_AES_X86_64=y
CONFIG_CRYPTO_AES_NI_INTEL=m
CONFIG_CRYPTO_CAMELLIA_AESNI_AVX_X86_64=m
CONFIG_CRYPTO_CAMELLIA_AESNI_AVX2_X86_64=m
CONFIG_CRYPTO_DEV_PADLOCK_AES=m

But it won't load through modprobe:

modprobe -v aes 
insmod /lib/modules/3.10.0-123.6.3.el7.x86_64/kernel/arch/x86/crypto/aesni-intel.ko 
modprobe: ERROR: could not insert 'aesni_intel': No such device

It could be a BIOS problem or a kernel issue. I'll check for an updated BIOS version

Comment 4 Dan Kenigsberg 2014-08-13 14:45:15 UTC
Maybe somebody from kernel can explain that.

Comment 6 Netbulae 2014-08-13 16:00:14 UTC
I finished updating the BIOS from 2.1b to 2.1c and it works properly no

Sorry, not a bug. But I'm not allowed to close it anymore

Comment 7 Dan Kenigsberg 2014-08-13 22:22:36 UTC
I'm happy to be at your service. Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.