Bug 1128870 - published repositories give 403 forbidden when attempting to navigate to the https address
Summary: published repositories give 403 forbidden when attempting to navigate to the ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Usability
Version: 6.0.3
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1242310 1320179 1351648
TreeView+ depends on / blocked
 
Reported: 2014-08-11 17:15 UTC by Aaron Thomas
Modified: 2019-06-13 08:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1242310 (view as bug list)
Environment:
Last Closed: 2015-03-19 20:30:43 UTC


Attachments (Terms of Use)

Description Aaron Thomas 2014-08-11 17:15:06 UTC
Description of problem:

Published repositories give 403 forbidden when attempting to navigate to the https address


Version-Release number of selected component (if applicable):
Version 6.0.3

How reproducible:
Choose organization, then Content > Content Views, choose Content> repositories click the repository and try to navigate to 'Published At' link to receive.

Forbidden

You don't have permission to access /pulp/repos/ACME_Corporation/Library/content/dist/rhel/server/6/6Server/x86_64/os on this server.


Actual results:
403

Expected results:
browse https repo

Comment 1 RHEL Product and Program Management 2014-08-11 17:23:46 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 7 Dale 2014-12-03 15:41:43 UTC
Any Updates at all on this bug?

Comment 9 Mike McCune 2015-03-19 20:30:43 UTC
For any protected Red Hat Content the user must use the Debug Certificate to gain access to protected content:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.0/html-single/User_Guide/#Create_a_New_Organization_Debug_Certificate

Red Hat content synced from our CDN is always locked down via HTTPS and requires the certificate to access.


Note You need to log in before you can comment on or make changes to this bug.