Bug 112889 - usb<->rs-232 converter prints only garbage
usb<->rs-232 converter prints only garbage
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 08:53 EST by Kaj J. Niemi
Modified: 2007-04-18 13:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 01:31:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test fix 2 (10.80 KB, patch)
2004-01-19 20:55 EST, Pete Zaitcev
no flags Details | Diff

  None (edit)
Description Kaj J. Niemi 2004-01-05 08:53:35 EST
With kernel-2.6.0-1.23 a Magic Controller Technology USB<->RS-232
converter prints only garbage to the screen when connected to any
RS-232 equipment at any bit rate. The equipment at the other end of
the cable is known good and works.

Setserial /dev/ttyUSBS0 returns invalid argument.

Description of problem:
Jan  5 14:55:48 d120 kernel: hub 3-0:1.0: new USB device on port 2,
assigned address 2
Jan  5 14:55:49 d120 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Generic
Jan  5 14:55:49 d120 kernel: drivers/usb/core/usb.c: registered new
driver usbserial
Jan  5 14:55:49 d120 kernel: drivers/usb/serial/usb-serial.c: USB
Serial Driver core v2.0
Jan  5 14:55:49 d120 kernel: drivers/usb/serial/usb-serial.c: USB
Serial support registered for Magic Control Technology USB-RS232
Jan  5 14:55:49 d120 kernel: mct_u232 3-2:1.0: Magic Control
Technology USB-RS232 converter detected
Jan  5 14:55:49 d120 kernel: usb 3-2: Magic Control Technology
USB-RS232 converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
Jan  5 14:55:49 d120 kernel: drivers/usb/core/usb.c: registered new
driver mct_u232
Jan  5 14:55:49 d120 kernel: drivers/usb/serial/mct_u232.c: Magic
Control Technology USB-RS232 converter driver v1.2
Jan  5 14:55:49 d120 devlabel: devlabel service started/restarted

Version-Release number of selected component (if applicable):
kernel-2.6.0-1.23

How reproducible:
Always

Steps to Reproduce:
1. plug usb-serial converter
2. minicom
3. wait

Actual Results:  Prints garbage at any bit rate

Expected Results:  Echo something sane to the screen

Additional info:
Any thoughts?
Comment 1 Kaj J. Niemi 2004-01-16 12:18:37 EST
Still a problem with kernel-2.6.0-1.43
Comment 2 Kaj J. Niemi 2004-01-16 12:18:51 EST
Uh that would be 2.6.1-1.43 :)
Comment 3 Pete Zaitcev 2004-01-18 03:37:35 EST
I only saw it on 9600. 38400 works fine. The driver is made
out of reverse-engineered snooper traces, so I'm not surprised
it gets divisors wrong somewhere.

The setserial is not supported in most of USB serial sub-drivers.
But it's beside the point here.
Comment 4 Kaj J. Niemi 2004-01-18 08:54:40 EST
O-kay! is there anything I can do to help you out to fix this or would
you like to suggest another, known working, usb <-> rs232 converter?
Most console applications I use (Cisco routers/switches and Sun
servers) talk back at 9600 8N1. The Wise People over at International
Banana Machines decided to leave a standard 9-pin serial port out of
the Thinkpad T40p.

Wasn't aware of setserial not working on usb.
Comment 5 Pete Zaitcev 2004-01-19 20:55:08 EST
Created attachment 97119 [details]
Test fix 2
Comment 6 Pete Zaitcev 2004-01-19 20:58:33 EST
9600 is the victim, because it's the default speed after reboots.
It can fail to set 38400 as well, in the following scenario:

Run equipment on 38400.
Connect adapter.
Start kermit / minicom.
Disconnect (at this point, MCT structures are gone, but tty stays!)
Quit kermit / minicom.
Reconnect.
Start kermit / minicom again;
 -- at open time, wrong comparison prevents settings to be set
Comment 7 Kaj J. Niemi 2004-01-20 05:35:06 EST
Work at 9600 8N1 now as well. Tested it against Cisco equipment.
Comment 8 Kaj J. Niemi 2004-01-28 14:02:07 EST
I noticed one more thing... sending break from minicom doesn't work
(while it does using the same cable on another laptop connected to a
normal com-port). Should I file another bug? This is with 2.6.1-1.57.
Comment 9 Pete Zaitcev 2004-01-28 14:24:15 EST
Please go ahead and file.

There's quite a bit of functions which either usbserial or
various component drivers do not implement at all. I have
about two bugs about it already. I'll get back to it when I can.
Comment 10 Pete Zaitcev 2004-03-09 18:12:04 EST
Can this be closed?
Comment 11 Kaj J. Niemi 2004-03-10 01:31:19 EST
Yeah, this can be closed. Thanks.

Note You need to log in before you can comment on or make changes to this bug.