Bug 1128926 - keystone is unable to handle 'objectGUID' and 'objectSID' active directory attributes.
Summary: keystone is unable to handle 'objectGUID' and 'objectSID' active directory at...
Keywords:
Status: CLOSED DUPLICATE of bug 1138684
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone
Version: 5.0 (RHEL 7)
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
: 5.0 (RHEL 7)
Assignee: Nathan Kinder
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks: 1128799
TreeView+ depends on / blocked
 
Reported: 2014-08-11 20:59 UTC by John Trowbridge
Modified: 2018-12-09 18:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-18 22:48:42 UTC


Attachments (Terms of Use)

Description John Trowbridge 2014-08-11 20:59:29 UTC
Description of problem:

When using AD backend, Keystone can not handle values for the attributes:  ‘objectGUID’ and ‘objectSid’ which hold values of format:

['\x01\x07\x00\x02\x00\x00\x09\x05\x15\x00\x00\x006P~US#\xbd>H&\xfd\x1a\x06_\x00\x00']


How reproducible:
Need AD setup to reproduce, so I am going with the issue as reported by the customer.


Additional info:
Let me know what other data from the customer's environment would be useful.

Comment 5 Nathan Kinder 2014-09-18 22:48:42 UTC
This is a duplicate of a bug that was recently fixed where Keystone was not handling binary LDAP values.  Marking as a duplicate.

*** This bug has been marked as a duplicate of bug 1138684 ***


Note You need to log in before you can comment on or make changes to this bug.