Bug 1128928 - User can add the same permission to a role multiple times.
Summary: User can add the same permission to a role multiple times.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 21:17 UTC by Corey Welton
Modified: 2017-02-23 21:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 07:55:12 UTC


Attachments (Terms of Use)

Description Corey Welton 2014-08-11 21:17:12 UTC
Description of problem:
When user goes in to "Add permissions" for a role, those which user has already added can be added multiple times.

Version-Release number of selected component (if applicable):
Satellite-6.0.4-RHEL-6-20140806.0

How reproducible:


Steps to Reproduce:
1.  Create a new role, "foobar"
2.  foobar > Filters and permissions > Add permission
3.  Add role "access_dashboard"; submit
4.  Observe the newly added permission(s) on the role
5.  Repeat steps 2-4 a half dozen times.

Actual results:
Multiple instances of the role you've added

Expected results:
User should only be able to add role once.
TBH, I think the "Add permissions" option should be renamed to "Edit permissions", and the two tables where user can move roles back and forth should remember what has been added already, thus disallow dupes and allowing removal (which [removal] I think is a separate bz being written up)

Additional info:

Comment 1 Corey Welton 2014-08-11 21:31:29 UTC
nm, you can delete extraneous -- in the resulting perms list view, you can select the dropdown.  Regardless, core of bz is still valid.

Comment 3 Dominic Cleal 2014-08-12 07:55:12 UTC
This is deliberate, as filters are additive and you may build up a role with multiple filters with different search terms.


Note You need to log in before you can comment on or make changes to this bug.