Bug 1128930 - UI should have ability to view current permissions of a given role
Summary: UI should have ability to view current permissions of a given role
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Ohad Levy
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-11 21:18 UTC by sthirugn@redhat.com
Modified: 2014-08-11 21:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-11 21:38:58 UTC


Attachments (Terms of Use)
permissions page of a given role (58.42 KB, image/png)
2014-08-11 21:21 UTC, sthirugn@redhat.com
no flags Details

Description sthirugn@redhat.com 2014-08-11 21:18:25 UTC
Description of problem:
[RFE] UI should have ability to view current permissions of a given role

Version-Release number of selected component (if applicable):
Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Currently there is no way to view the permissions of a given role

Workaround:
- For a given role -> Filters and Permissions -> Add Permission -> Select some permission and click Submit.  Then I am taken to the Permissions page of that role (see screenshot)

Actual results:
But this is not accessible directly in UI - everytime I need to add a permission to view the list of all permissions.

Expected results:
The permissions of a given role should be readily viewable. Perhaps - change "Add permission" option of a role to "Edit permission" - clicking of which take me to the page which has all permissions of that role.

Additional info:

Comment 1 sthirugn@redhat.com 2014-08-11 21:21:08 UTC
Created attachment 925878 [details]
permissions page of a given role

Comment 3 sthirugn@redhat.com 2014-08-11 21:38:58 UTC
Not a bug.

Need to click on "Filters and Permissions" text and not anywhere else in that button.


Note You need to log in before you can comment on or make changes to this bug.