Bug 1128959 - valgrind-devel subpackage is not available for RHEL6?
Summary: valgrind-devel subpackage is not available for RHEL6?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: releng
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 00:51 UTC by Tom Lane
Modified: 2014-08-12 09:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 09:29:01 UTC


Attachments (Terms of Use)

Description Tom Lane 2014-08-12 00:51:13 UTC
Description of problem:
RHEL6 doesn't seem to have a separate -devel subpackage:
$ sudo yum install valgrind-devel
No package valgrind-devel available.
Error: Nothing to do

... and yet, the header files such as valgrind/memcheck.h are not present in the
base package.  This means programs that include valgrind client requests cannot be
compiled, which makes the RHEL6 package completely useless for my purposes.

Version-Release number of selected component (if applicable):
valgrind-3.8.1-3.2.el6.x86_64

How reproducible:
100% I imagine

Steps to Reproduce:
1. see description

Comment 1 Tom Lane 2014-08-12 00:57:52 UTC
I pulled down the RHEL6 SRPM and verified that the specfile knows about building the devel subpackage, so actually this bug probably belongs to distribution.  My memory is fuzzy about exactly who gets the blame though ...

Comment 4 Mark Wielaard 2014-08-12 09:17:22 UTC
It is available from the rhel-x86_64-server-optional-6 repository.

Comment 5 Lubos Kocman 2014-08-12 09:29:01 UTC
Hello,

as mentioned most of -devel packages are placed in the optional channels. Optional channel is available to any RHEL subscriber, it's just not turned on by default.

I'm marking this issue as not a bug.

Thanks for understanding

Lubos


Note You need to log in before you can comment on or make changes to this bug.