Bug 112899 - libmilter not available
libmilter not available
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Florian La Roche
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 12:08 EST by Greg Winterstein
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-19 06:43:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Winterstein 2004-01-05 12:08:18 EST
Description of problem:
Although the sendmail is compiled with milter support, libmilter is 
not available as part of the sendmail package. There used to be a 
packaged called sendmail-devel, but it does not appear to be 
available for RHEL 3.

Why would you compile in milter support in sendmail but not make the 
libmilter libraries available? Seems like a waste. You should compile 
milter out of sendmail or better yet, make libmilter and the headers 
available... perhaps something like the previously available sendmail-
devel.
Comment 1 Ronald Cole 2004-01-28 02:13:09 EST
For now, just rebuild the sendmail SRPM and install sendmail-devel.  
That said, I have a bad feeling that if you do this, then the next 
sendmail errata update from Red Hat will not install due to 
dependency problems.  Does Red Hat really expect us Enterprise 
customers to have to learn to live without anti-virus milters on 
their mail hubs?
Comment 2 Florian La Roche 2004-05-19 06:43:13 EDT
sendmail-devel is now available in RHN

Note You need to log in before you can comment on or make changes to this bug.