Bug 1128993 - org/apache/lucene/lucene-queryparser: 3.6.2-redhat-4 can't be found in FSW Maven offline repository
Summary: org/apache/lucene/lucene-queryparser: 3.6.2-redhat-4 can't be found in FSW Ma...
Keywords:
Status: CLOSED DUPLICATE of bug 1105052
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 03:39 UTC by Jason Shepherd
Modified: 2018-12-09 18:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 02:43:40 UTC
Type: Bug


Attachments (Terms of Use)
example settings.xml (1.11 KB, application/zip)
2014-08-12 03:39 UTC, Jason Shepherd
no flags Details

Description Jason Shepherd 2014-08-12 03:39:00 UTC
Created attachment 925903 [details]
example settings.xml

Description of problem:

Can't build BPM Service because of missing dependency. I setup an offline repository using the settings.xml attached. When building quickstarts/switchyard/bpm-service I get the following error:

[ERROR] Failed to execute goal on project switchyard-quickstart-bpm-service: Could not resolve dependencies for project org.switchyard.quickstarts:switchyard-quickstart-bpm-service:jar:1.1.1-p5-redhat-1: Could not find artifact org.apache.lucene:lucene-queryparser:jar:3.6.2-redhat-4 in fsw-6.0.0.GA-redhat-2-repository (file:///home/jshepher/.m2/fsw-6.0.0.GA-redhat-2-repository) -> [Help 1]


Steps to Reproduce:

1. Download and install FSW, and EAP repositories as per settings.xml
2. Remove any existing dependencies from local maven repository
3. mvn clean install -U


Actual results:

The error previously noted

Expected results:

The application is built without error


Additional info:

The dependency can be found in WFK 2.5

Comment 1 Jiri Sedlacek 2014-08-13 07:32:27 UTC
This will be fixed in next rollup patch, the same issue (https://bugzilla.redhat.com/show_bug.cgi?id=1105052) is already verified.

Comment 2 Jason Shepherd 2014-08-14 02:43:40 UTC

*** This bug has been marked as a duplicate of bug 1105052 ***


Note You need to log in before you can comment on or make changes to this bug.