Bug 1129004 - RFE: Use values from existing config in zanata init
Summary: RFE: Use values from existing config in zanata init
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Maven, Component-zanata-client
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Damian Jansen
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
: 1134146 (view as bug list)
Depends On: 1110627
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 04:54 UTC by Carlos Munoz
Modified: 2015-07-29 02:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: 3
Clone Of:
Environment:
Last Closed: 2015-07-29 02:10:40 UTC


Attachments (Terms of Use)

Description Carlos Munoz 2014-08-12 04:54:29 UTC
Description of problem:

- When a config file is found, ask to reuse or start from scratch
- Continue to backup the existing config as a timestamped file
- Offer values from the existing config as defaults. Explicitly show the value, not prefilled.
- Press enter (or similar) to use default values
- Preserve anything else including locale mappings and command hooks
- Try to preserve comments

Comment 1 Ding-Yi Chen 2014-09-24 23:59:04 UTC
*** Bug 1134146 has been marked as a duplicate of this bug. ***

Comment 2 Zanata Migrator 2015-07-29 02:10:40 UTC
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-139


Note You need to log in before you can comment on or make changes to this bug.