Bug 1129008 - Dist-geo-rep: An API to check any active geo-rep session for the volume.
Summary: Dist-geo-rep: An API to check any active geo-rep session for the volume.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 05:32 UTC by Kotresh HR
Modified: 2015-05-14 17:35 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.7.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-14 17:26:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2014-08-12 05:32:36 UTC
Description of problem:
Snapshot needs an API to fail the CLI if any geo-rep session is active
for that volume. 

Version-Release number of selected component (if applicable):


How reproducible:
Not Applicable

Steps to Reproduce:
1.
2.
3.

Actual results:
There is no API in geo-rep that tells whether the volume as any active geo-rep session.

Expected results:
An API is required for snapshot from geo-rep end to say any active geo-rep session for that volume.

Additional info:

Comment 1 Anand Avati 2014-08-12 05:38:09 UTC
REVIEW: http://review.gluster.org/8459 (geo-rep/glusterd: API to check active geo-rep session for the volume.) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 2 Anand Avati 2014-08-12 07:41:09 UTC
REVIEW: http://review.gluster.org/8459 (geo-rep/glusterd: API to check active geo-rep session for the volume) posted (#2) for review on master by Sachin Pandit (spandit@redhat.com)

Comment 3 Anand Avati 2014-08-19 07:43:48 UTC
REVIEW: http://review.gluster.org/8459 (geo-rep/glusterd: API to check active geo-rep session for the volume) posted (#3) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 4 Anand Avati 2014-08-20 07:45:42 UTC
REVIEW: http://review.gluster.org/8459 (geo-rep/glusterd: API to check active geo-rep session for the volume) posted (#4) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 5 Anand Avati 2014-08-21 11:53:00 UTC
REVIEW: http://review.gluster.org/8459 (geo-rep/glusterd: API to check active geo-rep session for the volume) posted (#5) for review on master by Krishnan Parthasarathi (kparthas@redhat.com)

Comment 6 Anand Avati 2014-08-21 13:28:48 UTC
COMMIT: http://review.gluster.org/8459 committed in master by Krishnan Parthasarathi (kparthas@redhat.com) 
------
commit bbb7da5abe6b7275d9b633f8ad7692a4f2132c71
Author: Kotresh H R <khiremat@redhat.com>
Date:   Fri Aug 8 17:17:20 2014 +0530

    geo-rep/glusterd: API to check active geo-rep session for the volume
    
    Requirement:
    Snapshot needs an API to fail the CLI if any geo-rep session is active
    for that volume.
    
    Solution:
    A function "gd_vol_is_geo_rep_active" is provided to check if any
    geo-rep session is active for that volume. An in memory dict called
    'gsync_running_slaves' is maintained in 'volinfo' structure to keep
    track of active geo-rep session for the volume. The key
    'slavenode::slavevol' with value 'running' is added whenever geo-rep
    is started/resumed into the dict and the same is removed if
    stopped/paused. So the 'count' in dict is used to decide whether the
    geo-rep is active or not for that volume.
    
    Also added "this->name" in gf_log in routines which this patch is
    touched.
    
    Change-Id: I2b5de7dd686541c6b89c0fd0f7a4dbc92eecfac5
    BUG: 1129008
    Signed-off-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-on: http://review.gluster.org/8459
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
    Tested-by: Krishnan Parthasarathi <kparthas@redhat.com>

Comment 7 Niels de Vos 2015-05-14 17:26:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 8 Niels de Vos 2015-05-14 17:28:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:13 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.