Bug 1129015 - cvpcb libraries missing; attempt to load from GitHub fails
Summary: cvpcb libraries missing; attempt to load from GitHub fails
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kicad
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 06:03 UTC by Lubomir Rintel
Modified: 2016-07-19 12:00 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 12:00:28 UTC


Attachments (Terms of Use)
Screenshot (76.82 KB, image/png)
2014-08-12 06:03 UTC, Lubomir Rintel
no flags Details

Description Lubomir Rintel 2014-08-12 06:03:05 UTC
Created attachment 925919 [details]
Screenshot

Description of problem:

None of the libraries are reachable. /usr/share/kicad/template/fp-lib-table only contains references to GitHub, libraries from other /usr/share/kicad/template/fp-lib-table.for-* files are not shipped with the package.

Version-Release number of selected component (if applicable):

kicad-2014.03.13-6.rev4744.fc21.i686

How reproducible:

Always

Steps to Reproduce:
1. rm ~/fp-lib-table
2. cvpcb

Actual results:

See attached screenshot.

Expected results:

Profit.

Comment 1 h2obrain 2014-10-09 09:05:26 UTC
You need to add -DBUILD_GITHUB_PLUGIN=ON to cmake
Also it seems that the automatic build is broken since a long time.
To build kicad from the sources i had to "sudo ln -s /usr/bin/wx-config-3.0 /usr/bin/wx-config"

Comment 2 Lubomir Rintel 2014-10-09 16:01:45 UTC
(In reply to h2obrain from comment #1)
> You need to add -DBUILD_GITHUB_PLUGIN=ON to cmake

Yep, it makes some sense. Aside from that, I guess we want to ship the libraries packaged and not rely on GitHub or even internet connectivity.

> Also it seems that the automatic build is broken since a long time.
> To build kicad from the sources i had to "sudo ln -s /usr/bin/wx-config-3.0
> /usr/bin/wx-config"

Worked for not "long time" ago. But yes, I guess it needs fixing.

Comment 3 Romain Deterre 2014-11-27 14:24:16 UTC
(In reply to Lubomir Rintel from comment #2)
> Yep, it makes some sense. Aside from that, I guess we want to ship the
> libraries packaged and not rely on GitHub or even internet connectivity.

Would it be possible to ship packaged libraries and still provide easy access to the Github repos for users who want access to the latest footprints and components?

Comment 4 Lubomir Rintel 2014-11-30 16:41:49 UTC
Jaromir, I'm wondering if this makes sense? It's surely not beautiful, but I can't really see other way out.

http://koji.fedoraproject.org/koji/taskinfo?taskID=8264456
http://pkgs.fedoraproject.org/cgit/kicad.git/log/?h=rawhide/user/lkundrak/fp-lib

Comment 5 Jaromír Cápík 2014-12-09 13:18:58 UTC
Hello guys. Sorry for the late response ... 

(In reply to Lubomir Rintel from comment #2)
> (In reply to h2obrain from comment #1)
> > You need to add -DBUILD_GITHUB_PLUGIN=ON to cmake
> 
> Yep, it makes some sense. Aside from that, I guess we want to ship the
> libraries packaged and not rely on GitHub or even internet connectivity.

Yeah, we want to include the libraries. The question is how that comes it passed my tests. Going to check what went wrong and look at the patches.

Comment 6 Jaromír Cápík 2014-12-15 18:25:47 UTC
(In reply to Lubomir Rintel from comment #4)
> Jaromir, I'm wondering if this makes sense? It's surely not beautiful, but I
> can't really see other way out.
> 
> http://koji.fedoraproject.org/koji/taskinfo?taskID=8264456
> http://pkgs.fedoraproject.org/cgit/kicad.git/log/?h=rawhide/user/lkundrak/fp-
> lib

Looks like what we need ...

hopefully the -DBUILD_GITHUB_PLUGIN=ON switch will do the c#3 job without affecting your change. Pity the build takes ages.

Comment 7 Jaromír Cápík 2014-12-15 19:12:40 UTC
Unfortunately the new version brings more troubles with the new fp_lib_table format and conversion of legacy entries. Pity I didn't notice prior doing the upgrade. These could be considered regressions.

Comment 8 Jaromír Cápík 2014-12-15 19:54:57 UTC
When I add the old mods in the library list and choose the Legacy plugin type, the cvpcb can find the mod content, but the conversion cause crashes and without the conversion the parts stay unassigned. I'm going to push your patch, but ... it needs more love.

Comment 9 Fedora Update System 2015-01-02 13:08:54 UTC
kicad-2014.03.13-9.rev4744.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kicad-2014.03.13-9.rev4744.fc21

Comment 10 Fedora Update System 2015-01-03 08:31:15 UTC
kicad-2014.03.13-10.rev4744.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/kicad-2014.03.13-10.rev4744.fc21

Comment 11 Fedora Update System 2015-01-17 05:49:39 UTC
kicad-2014.03.13-10.rev4744.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Eric Kuzmenko 2015-04-16 02:03:27 UTC
The bug is still present!

Comment 13 Eric Kuzmenko 2015-04-16 03:41:18 UTC
I apologize, although the GitHub plugin still isn't enabled, pointing the library path for each for each .pretty modules to local snapshot inside the environment variable 'KISYSMOD' (/usr/share/kicad/modules) and setting each Plugin Type to 'KiCad' works fine. Capacitors.pretty and lut.pretty are missing, you can find the Capacitors.pretty modules here: https://github.com/Twistx77/Capacitors.pretty/commit/918fb1a9bf9db1404719ae07ebe97826eba24688

Although apparently on March 19 2014 "All Capacitors have been moved to Capacitors_ThroughHole.pretty"
Commit: https://github.com/Twistx77/Capacitors.pretty/commit/918fb1a9bf9db1404719ae07ebe97826eba24688

So it's up to you what you want to do.

I was unable to find the lut.pretty modules though.

Comment 14 Fedora End Of Life 2015-11-04 15:57:33 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 15 Fedora End Of Life 2015-12-02 03:23:33 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Comment 16 Fedora End Of Life 2016-07-19 12:00:28 UTC
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.