Bug 112904 - undefined symbol: mysql_ssl_set
undefined symbol: mysql_ssl_set
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: perl-DBD-MySQL (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks: 187539
  Show dependency treegraph
 
Reported: 2004-01-05 13:46 EST by Bill Peck
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0319
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 15:25:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2004-01-05 13:46:37 EST
Description of problem:
While trying to install TIE::DBI I ran across the following problem
while doing a make test.

install_driver(mysql) failed: Can't load
'/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mysql.so'
for module DBD::mysql:
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/DBD/mysql/mysql.so:
undefined symbol: mysql_ssl_set at
/usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.

This seems to be a problem with the perl-DBD-MySQL package.

Version-Release number of selected component (if applicable):
perl-DBD-MySQL-2.1021-3

How reproducible:
everytime

Steps to Reproduce:
1. Install perl-DBD-MySQL-2.1021-3
2. Compile TIE::DBI
3. make test in TIE::DBI directory
  
Actual results:
fails to load mysql DBD library

Expected results:
should pass test

Additional info:
Comment 1 Jason Vas Dias 2006-03-17 12:35:42 EST
OK, this bug is now fixed with perl-DBD-MySQL-2.1021-4 - sorry for the long
delay in processing this bug report.

The problem was, that mysql-3.23.58.16.RHEL3.1 does NOT enable SSL, but the 
perl-DBD-MySQL module was compiled to enable mysql SSL support by default.

If the Tie::DBI tests were run WITHOUT the 'PERL_DL_NONLAZY=1', then they
all passed; but the default MM::Unix 'make test' command is:
   PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" 
"test_harness(0,'blib/lib','blib/arch')" t/*.t
ie. even before the fix, if you removed the PERL_DL_NONLAZY=1, all Tie::DBI
tests succeed. But with PERL_DL_NONLAZY=1, then DynaLoader barfs with the
'undefined symbol: mysql_ssl_set' error, because libmysqlclient indeed does
not contain that symbol.

Perhaps it is time to consider rebuilding mysql for RHEL-3, with SSL enabled
(the mysql RHEL-3 rpm has not been built since 2003).
Comment 2 Tom Lane 2006-03-17 15:36:24 EST
mysql's SSL support is pretty flaky even in the 4.1 branch; I shudder to think
of how well it (probably doesn't) work in 3.23.58.  Rather than getting involved
in trying to support a new feature in RHEL3, I'd suggest rebuilding
perl-DBD-MySQL without SSL.
Comment 10 Red Hat Bugzilla 2006-05-03 15:25:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0319.html

Note You need to log in before you can comment on or make changes to this bug.