Bug 1129054 - mgetty rpm has wrong "conflicts" on "hylafax+": it should be in mgetty-sendfax
Summary: mgetty rpm has wrong "conflicts" on "hylafax+": it should be in mgetty-sendfax
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mgetty
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Sekletar
QA Contact: Martin Žember
URL:
Whiteboard:
: 1128439 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 07:50 UTC by giulioo
Modified: 2015-07-13 04:14 UTC (History)
3 users (show)

Fixed In Version: mgetty-1.1.36-28.el7
Doc Type: Bug Fix
Doc Text:
Cause: Conflicts: hylafax+ in main mgetty package. Consequence: User unable to install both hylafax+ and mgetty at the same time. Fix: Move Conflicts: hylafax+ to mgetty-sendfax (actually conflicting) sub-package. Result: User able to install mgetty and hylafax+ at the same time. Note that hylafax+ is not part of the RHEL but it is included in EPEL.
Clone Of:
: 1129098 (view as bug list)
Environment:
Last Closed: 2014-10-22 12:17:56 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1681 normal SHIPPED_LIVE mgetty bug fix update 2014-10-22 16:17:48 UTC

Description giulioo 2014-08-12 07:50:25 UTC
Description of problem:

The mgetty rpm explicitly declares a "conflicts" with the hylafax+ package, but this is wrong since the "conflicts" should be declared by the mgetty-sendfax sub-package, not mgetty itself.
 

Version-Release number of selected component (if applicable):
 mgetty-1.1.36-26.el7.x86_64.rpm


Steps to Reproduce:

$ rpm -qp --conflicts mgetty-1.1.36-26.el7.x86_64.rpm
hylafax+

$ rpm -qp --conflicts mgetty-sendfax-1.1.36-26.el7.x86_64.rpm
$

$ rpm -qa|grep ^mgetty
mgetty-1.1.36-26.el7.x86_64
$

# rpm -Uvh hylafax+-5.5.5-2.el7.x86_64.rpm
error: Failed dependencies:
        hylafax+ conflicts with (installed) mgetty-1.1.36-26.el7.x86_64
#


Expected results:
mgetty-sendfax should declare a conflict with hylafax+.
mgetty should not.

Additional information:
mgetty (main rpm) and hylafax+ can coexist with no problem.

Comment 1 Michal Sekletar 2014-08-12 07:59:58 UTC
*** Bug 1128439 has been marked as a duplicate of this bug. ***

Comment 3 Michal Sekletar 2014-08-12 08:07:23 UTC
Thanks, for the report. I'll try to deliver fix in RHEL-7.1.

Comment 9 Michal Sekletar 2014-09-24 12:36:31 UTC
(In reply to Martin Žember from comment #8)
> BTW, in RHEL-6, mgetty-sendfax does not conflict with hylafax. Is it a bug,
> or is it different there?

That's ok, packages will conflict implicitly. Note that explicit Conflicts: was added because of packaging policy in Fedora. To verify try installing mgetty and hylafax+ and mgetty-sendfax and hylafax+. Former combination will be installed without problems while later installation will fail due to conflict.

Comment 11 errata-xmlrpc 2014-10-22 12:17:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1681.html


Note You need to log in before you can comment on or make changes to this bug.