Bug 1129059 - e-mail sent by <reservesys/> does not include a link to the recipe
Summary: e-mail sent by <reservesys/> does not include a link to the recipe
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: general
Version: 0.17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: 19.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 07:55 UTC by Dan Callaghan
Modified: 2018-02-06 00:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 07:18:33 UTC


Attachments (Terms of Use)

Description Dan Callaghan 2014-08-12 07:55:30 UTC
The recipe link is very important, for example so I can click through and return the system (since there is no return2beaker.sh). The body of the mail even advises doing exactly that, but doesn't provide a link for it.

Comment 3 Dan Callaghan 2014-11-20 07:44:43 UTC
I (unwittingly) fixed this bug in this commit:

https://git.beaker-project.org/cgit/beaker/commit/?id=1aebdf43e89891bb33ab7a2d7d69412e1ce0edb3

which will be in 19.0.

Comment 4 Dan Callaghan 2014-11-20 07:45:59 UTC
Steps to reproduce:
1. Schedule a job like this:
...
<recipe>
  ...
  <task name="/distribution/install"/>
  <reservesys/>
</recipe>
2. Wait for installation to complete and reservation e-mail to be sent

Expected results:
Reservation e-mail contains a link to the recipe in Beaker's web UI.

Comment 6 Dan Callaghan 2014-11-25 07:18:33 UTC
Beaker 19.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.