Bug 112915 - LTC5726-Network scripts report error when starting/stopping a TR device.
LTC5726-Network scripts report error when starting/stopping a TR device.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-01-05 16:49 EST by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 10:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2004-01-05 16:49:17 EST
The following has be reported by IBM LTC:  
Network scripts report error when starting/stopping a TR device.
Hardware Environment: iSeries 64bit partition with native Token Ring.

Software Environment: RHEL 3


Steps to Reproduce:
1. Network install over a token ring device.
2. Boot the system

Actual Results:
When the network is started during boot the following message is reported:

/etc/init.d/network: line 1: Ring: command not found

The same message is reported when starting and stopping networking via
SysV
scripting.

Expected Results:
The error message is not expected when starting and stopping the Token
Ring device.

Additional Information:
The message can be alleviated by changing the 'TYPE' line in
/etc/sysconfig/network-scripts/ifcfg-tr0 from:

'TYPE=Token Ring'

to 

'TYPE="Token Ring" 'Glen/Greg - please ask Red Hat to change the
network script for token ring
as suggested by Jay Bryant above.  Thanks.
Comment 1 IBM Bug Proxy 2004-02-06 09:49:37 EST
----- Additional Comments From khoa@us.ibm.com  2004-02-06 09:48 -------
I've put this on RHEL3 QU3 list as a Sev 3. 
Comment 3 Mike Gahagan 2004-08-12 11:19:00 EDT
IBM,

In doing some recent testing for a different problem, I have noticed
that we are not hitting this bug. I looked at the ifcfg-tr0 file and
there was no TYPE= line. The interface will work just fine without it.
Using Token Ring for TYPE without the quotes reproduced this bug as
described, adding in the quotes made it go away. At most this is a
cosmetic issue. In our test environment, we used kudzu to
add/configure the interface. We need to better understand how the
TYPE=Token Ring got there in the first place. Did you use
redhat-config-network by itself to configure the interface (no other
tools or hand-editing of the file)?

Also, please make sure this is reproduceable on U2 (or the U3 beta)
Comment 4 Mike Gahagan 2004-08-12 14:28:53 EDT
I think the problem lies in r-c-network in tokenringhardware.py. Near
the end of the script, we set self.hw.Type = 'Token Ring'. This
eventually gets written out as "TYPE=Token Ring" in ifcfg-tr0. The
fact that "Token Ring" isn't quoted makes bash think Ring is a command
later on. 

I see 2 ways to fix this;

condense Token Ring to 1 word (this is why all the other interfaces
don't have this problem AFACT)

Fix whatever writes the ifcfg files to quote whatever is after "TYPE="

I am setting this to all platforms as this is a platform independant bug.


Comment 5 Harald Hoyer 2004-08-16 06:34:45 EDT
which version of rhpl is involved here?
Comment 6 Mike Gahagan 2004-09-20 10:35:27 EDT
rhpl-0.110.6.1 is what I believe I was using. I can try it again, but
it will be a little while until I have access to something with a
token ring card . It appears that r-c-network won't write anything out
so that I could see if the problem is still there or not unless the
modules loads.

Comment 7 Harald Hoyer 2004-10-05 09:48:42 EDT
No problem with
# rpm -q rhpl
rhpl-0.110.4-1
Comment 8 Harald Hoyer 2004-10-05 09:51:06 EDT
and this has not changed since...
Comment 9 Harald Hoyer 2004-10-05 09:51:56 EDT
Steps to Reproduce:
1. Network install over a token ring device.
2. Boot the system

I don't think anaconda writes TYPE=
Comment 10 Harald Hoyer 2004-10-05 10:00:52 EDT
# cat /etc/sysconfig/network-scripts/ifcfg-tr0
DEVICE=tr0
BOOTPROTO=dhcp
ONBOOT=no

This file is enough to experiment with r-c-network... Just start it
and the "Save".

# cat /etc/sysconfig/network-scripts/ifcfg-tr0
DEVICE=tr0
BOOTPROTO=dhcp
ONBOOT=no
TYPE='Token Ring'

I see no problem here..
Comment 11 Harald Hoyer 2004-10-05 10:17:59 EDT
Maybe a bug in anaconda/network.py, which does not add ''
Comment 12 Jeremy Katz 2004-10-05 10:41:12 EDT
This was included in RHEL3 U3.

network.py
revision 1.24.6.14
date: 2004/08/03 03:13:19;  author: notting;  state: Exp;  lines: +1 -1
token ring fix here as well (#128586)
Comment 13 IBM Bug Proxy 2004-10-05 13:16:11 EDT
----- Additional Comments From rayda@us.ibm.com  2004-10-05 13:15 EDT -------
I see no such messages in the boot up of the shipped QU3.  My token ring works 
fine.  Closing. 
Comment 14 IBM Bug Proxy 2004-10-05 13:21:15 EDT
----- Additional Comments From rayda@us.ibm.com  2004-10-05 13:17 EDT -------
Sheesh, there's a lot of states to get through to find the CLOSED option.... 

Note You need to log in before you can comment on or make changes to this bug.