Bug 112916 - /etc/localtime symbolic link to a file outside of / filesystem => problem
/etc/localtime symbolic link to a file outside of / filesystem => problem
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-01-05 17:54 EST by monniaux
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-06 01:01:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description monniaux 2004-01-05 17:54:29 EST
Description of problem:

If /etc/localtime is a symbolic link to a file under /usr (apparently,
some setup tools set the timezone that way) and /usr is not on /, then
hwclock in /etc/rc.sysinit is invoked when /etc/localtime points on a
non-existent file, and thus the local timezone is assumed to be UTC.

If the real timezone is NOT UTC, and the hardware clock is set in
local time, the system clock gets offset by some amount with respect
to the hardware clock.

Version-Release number of selected component (if applicable):


How reproducible:always

Steps to Reproduce:
1.check that /etc/localtime is a symbolic link to a partition outside
/ (and thus not mounted immediately at bootup time)
2.set the local time zone to something else than UTC and the hardware
clock mode to local time
3.reboot
  
Actual results:
The system clock gets an incorrect time.

Expected results:
The system clock should get the time from the hardware clock.

Additional info:
Comment 1 Bill Nottingham 2004-01-06 01:01:12 EST
Your system is misconfigured. /etc/localtime should be a file. There
was a redhat-config-time bug around this timeframe in that it made it
a symlink, it's since been fixed.

Note You need to log in before you can comment on or make changes to this bug.