Bug 1129216 - authconfig command fails to run during post kickstart phase while REALM Integration
Summary: authconfig command fails to run during post kickstart phase while REALM Integ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Stephen Benjamin
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 10:33 UTC by Kedar Bidarkar
Modified: 2014-09-11 12:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:22:26 UTC


Attachments (Terms of Use)

Description Kedar Bidarkar 2014-08-12 10:33:28 UTC
Description of problem:

authconfig command fails to run during post kickstart phase.

I think the below error is thrown when, 

=> authconfig --nisdomain ${idm_domain} --update


/tmp/ks-script-jja4Lb: line 90: [: 9: unary operator expected
Traceback (most recent call last):
  File "/usr/sbin/authconfig", line 923, in <module>
    sys.exit(module.run())
  File "/usr/sbin/authconfig", line 499, in run
    self.readAuthInfo()
  File "/usr/sbin/authconfig", line 342, in readAuthInfo
    self.info = authinfo.read(self.printError)
  File "/usr/share/authconfig/authinfo.py", line 921, in read
    info.read()
  File "/usr/share/authconfig/authinfo.py", line 2212, in read
    self.readSSSD(ref)
  File "/usr/share/authconfig/authinfo.py", line 1640, in readSSSD
    domain = self.sssdConfig.get_domain(domname)
  File "/usr/lib/python2.6/site-packages/SSSDConfig/__init__.py", line 1800, in get_domain
    domain.set_option(option, value)
  File "/usr/lib/python2.6/site-packages/SSSDConfig/__init__.py", line 1139, in set_option
    self.add_provider(value, provider)
  File "/usr/lib/python2.6/site-packages/SSSDConfig/__init__.py", line 1192, in add_provider
    raise NoSuchProviderSubtypeError(provider_type)
SSSDConfig.NoSuchProviderSubtypeError: sudo


Version-Release number of selected component (if applicable):
sat6-GA-snap4

How reproducible:
always

Steps to Reproduce:
1. When integrating Sat6 with REALM
2.
3.

Actual results:
Fails with the above error.

Expected results:
authconfig configuration should be smooth.

Additional info:

Comment 1 RHEL Product and Program Management 2014-08-12 10:43:12 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Stephen Benjamin 2014-08-12 13:39:01 UTC
SSSD version was being improperly compared, and needed to be done in arithmetic context.

Upstream:
  https://github.com/theforeman/community-templates/pull/102

Comment 7 Kedar Bidarkar 2014-08-19 19:21:34 UTC
idm_register still has the old stuff and not the new "SSSD version comparisons in arithmetic context".

if [ $sssd_minor >= 11 ] || [ $sssd_major > 1 ]

==========================================

Looks like the changes are not in.



Tested with Sat6-GA-Snap5.


Installed Packages

    candlepin-0.9.23-1.el6_5.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23-1.el6_5.noarch
    candlepin-tomcat6-0.9.23-1.el6_5.noarch
    createrepo-0.9.9-21.2.pulp.el6sat.noarch
    elasticsearch-0.90.10-4.el6sat.noarch
    katello-1.5.0-28.el6sat.noarch
    katello-ca-1.0-1.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-installer-0.0.59-1.el6sat.noarch
    m2crypto-0.21.1.pulp-10.el6sat.x86_64
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-3.el6sat.noarch
    pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
    pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
    pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
    pulp-server-2.4.0-0.30.beta.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-puppet-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-rpm-common-2.4.0-0.30.beta.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-82.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-12.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.0-1.1.el6sat.noarch

Comment 9 Kedar Bidarkar 2014-08-22 11:10:46 UTC
Tested with Sat6-GA-snap6


[root@xxxxx ~]# nisdomainname
katellolabs.org


Installed Packages

    candlepin-0.9.23-1.el6_5.noarch
    candlepin-common-1.0.1-1.el6_5.noarch
    candlepin-scl-1-5.el6_4.noarch
    candlepin-scl-quartz-2.1.5-5.el6_4.noarch
    candlepin-scl-rhino-1.7R3-1.el6_4.noarch
    candlepin-scl-runtime-1-5.el6_4.noarch
    candlepin-selinux-0.9.23-1.el6_5.noarch
    candlepin-tomcat6-0.9.23-1.el6_5.noarch
    createrepo-0.9.9-21.2.pulp.el6sat.noarch
    elasticsearch-0.90.10-6.el6sat.noarch
    katello-1.5.0-29.el6sat.noarch
    katello-certs-tools-1.5.6-1.el6sat.noarch
    katello-default-ca-1.0-1.noarch
    katello-installer-0.0.60-1.el6sat.noarch
    katello-server-ca-1.0-1.noarch
    m2crypto-0.21.1.pulp-10.el6sat.x86_64
    mod_wsgi-3.4-1.pulp.el6sat.x86_64
    pulp-katello-0.3-3.el6sat.noarch
    pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
    pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
    pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
    pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
    pulp-server-2.4.0-0.30.beta.el6sat.noarch
    python-gofer-qpid-1.3.0-1.el6sat.noarch
    python-isodate-0.5.0-1.pulp.el6sat.noarch
    python-kombu-3.0.15-12.pulp.el6sat.noarch
    python-pulp-bindings-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-puppet-common-2.4.0-0.30.beta.el6sat.noarch
    python-pulp-rpm-common-2.4.0-0.30.beta.el6sat.noarch
    python-qpid-0.22-14.el6sat.noarch
    python-qpid-qmf-0.22-37.el6.x86_64
    qpid-cpp-client-0.22-42.el6.x86_64
    qpid-cpp-server-0.22-42.el6.x86_64
    qpid-cpp-server-linearstore-0.22-42.el6.x86_64
    qpid-java-client-0.22-6.el6.noarch
    qpid-java-common-0.22-6.el6.noarch
    qpid-proton-c-0.7-1.el6.x86_64
    qpid-qmf-0.22-37.el6.x86_64
    qpid-tools-0.22-12.el6.noarch
    ruby193-rubygem-katello-1.5.0-85.el6sat.noarch
    rubygem-hammer_cli_katello-0.0.4-14.el6sat.noarch
    rubygem-smart_proxy_pulp-1.0.1-1.1.el6sat.noarch

Comment 10 Kedar Bidarkar 2014-08-22 11:11:34 UTC
authconfig command is run successfully and nisdomain set.

Comment 11 Bryan Kearney 2014-09-11 12:22:26 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.