Bug 1129225 - hv_vapic flag cause win2008r2 guest black screen during booting
Summary: hv_vapic flag cause win2008r2 guest black screen during booting
Keywords:
Status: CLOSED DUPLICATE of bug 1091818
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 10:54 UTC by FuXiangChun
Modified: 2014-08-12 13:51 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 13:51:18 UTC


Attachments (Terms of Use)

Description FuXiangChun 2014-08-12 10:54:50 UTC
Description of problem:
Boot guest with "/usr/libexec/qemu-kvm -m 12G -smp 64 -cpu Haswell,hv_vapic"

then use remote viewer client to connect guest. e.g
remote-viewer spice://10.16.44.159:5931

guest show black screen

Version-Release number of selected component (if applicable):
host kernel
3.10.0-131.el7.x86_64

host qemu-kvm:
qemu-kvm-1.5.3-67.el7.x86_64
qemu-kvm-rhev-2.1.0-1.el7.x86_64

seabios-1.7.5-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -m 12G -smp 64 -cpu Haswell,hv_vapic,family=0xf -usb -device usb-tablet -drive file=win2k8.qcow2,format=qcow2,if=none,id=drive-virtio0,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio0,id=virtio-blk-pci0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,mac=00:10:1a:75:50:01,bus=pci.0,addr=0x4,id=virtio-net-pci0 -uuid e8bfe003-1426-4924-b0ac-bd42360a1c36 -rtc base=localtime,clock=host,driftfix=slew -no-kvm-pit-reinjection -name intel-max-sut -monitor stdio -boot menu=on  -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -spice disable-ticketing,port=5931 -vga qxl

2.remote-viewer connect to guest
remote-viewer spice://10.16.44.159:5931

3.

Actual results:
guest black screen

Expected results:
guest works

Additional info:
host info:
IvyBridge-EX

processor	: 119
vendor_id	: GenuineIntel
cpu family	: 6
model		: 62
model name	: Intel(R) Xeon(R) CPU E7-4880 v2 @ 2.50GHz
stepping	: 7
microcode	: 0x70d
cpu MHz		: 2443.652
cache size	: 38400 KB
physical id	: 3
siblings	: 30
core id		: 14
cpu cores	: 15
apicid		: 125
initial apicid	: 125
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips	: 4997.30
clflush size	: 64
cache_alignment	: 64
address sizes	: 46 bits physical, 48 bits virtual
power management:

Comment 1 FuXiangChun 2014-08-12 13:51:18 UTC
This bug is the same with bug 1091818, and kernel kernel-3.10.0-143.el7 fixed this bug. so dup it to bug 1091818.

*** This bug has been marked as a duplicate of bug 1091818 ***


Note You need to log in before you can comment on or make changes to this bug.