Bug 1129246 - update of entity in ovirt-shell not reflected in engine
Summary: update of entity in ovirt-shell not reflected in engine
Keywords:
Status: CLOSED DUPLICATE of bug 1122546
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-cli
Version: 3.5
Hardware: All
OS: All
medium
urgent
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Lukas Svaty
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 11:30 UTC by Lukas Svaty
Modified: 2016-02-10 19:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 08:17:04 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Lukas Svaty 2014-08-12 11:30:30 UTC
Description of problem:
update in ovirt-shell not working on entities

Version-Release number of selected component (if applicable):
ovirt-rc1

How reproducible:
100%

Steps to Reproduce:
1. ovirt-shell --insecure (+log with credentials)
2. [oVirt shell (connected)]# update cluster bar --name "foo"

id                                         : 00000001-0001-0001-0001-000000000349
name                                       : bar
description                                : The default server cluster
ballooning_enabled                         : False
cpu-id                                     : Intel Nehalem Family
cpu-architecture                           : X86_64
data_center-id                             : 00000002-0002-0002-0002-0000000003a6
error_handling-on_error                    : migrate
gluster_service                            : False
ha_reservation                             : False
ksm-enabled                                : False
memory_policy-overcommit-percent           : 100
memory_policy-transparent_hugepages-enabled: True
optional_reason                            : False
scheduling_policy-id                       : b4ed2332-a7ac-4d5f-9596-99a439cb2812
scheduling_policy-name                     : none
scheduling_policy-policy                   : none
threads_as_cores                           : False
trusted_service                            : False
tunnel_migration                           : False
version-major                              : 3
version-minor                              : 5
virt_service                               : True

Actual results:
As you can see in results name did not change.

Expected results:
Let me update entities with ovirt-shell :)

Additional info:
engine log:
2014-08-12 13:29:20,457 INFO  [org.ovirt.engine.core.bll.UpdateVdsGroupCommand] (ajp--127.0.0.1-8702-2) [486d7132] Running command: UpdateVdsGroupCommand internal: false. Entities affected :  ID: 00000001-0001-0001-0001-000000000349 Type: VdsGroups
2014-08-12 13:29:20,465 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-2) [486d7132] Correlation ID: 486d7132, Call Stack: null, Custom Event ID: -1, Message: Host cluster bar was updated by admin

Even the log is lying, nothing was updated.

Comment 1 Juan Hernández 2014-08-20 08:17:04 UTC

*** This bug has been marked as a duplicate of bug 1122546 ***


Note You need to log in before you can comment on or make changes to this bug.