Bug 1129268 - SMB:While doing rename from cifs mount observed huge logging in client logs with huge lookups for an operation [NEEDINFO]
Summary: SMB:While doing rename from cifs mount observed huge logging in client logs w...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Poornima G
QA Contact: Vivek Das
URL:
Whiteboard: core
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 12:46 UTC by surabhi
Modified: 2018-04-20 09:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-20 09:50:27 UTC
sanandpa: needinfo? (vdas)


Attachments (Terms of Use)

Description surabhi 2014-08-12 12:46:35 UTC
Description of problem:
**********************************

While executing the rename of a file from cifs mount on a DHT volume where one of the brick is down, observed huge logging in client logs where it shows too many lookups happened for the rename operation.
The case expected rename to fail which worked as expected but for one rename operation huge number of lookups has happened.

Version-Release number of selected component (if applicable):
glusterfs-3.6.0.27-1.el6rhs.x86_64

How reproducible:
tried with rename command

Steps to Reproduce:
1.Create a volume, mount it via cifs
2.create few dirs and files on mount point.
3.bring down one of the brick
4.try to rename a file on up subvolume to the file name which is on down sub-volume.
5. check the client logs

Actual results:
Huge lookups for rename opertaion

Expected results:
There should be these many look ups.Tried the same test from fuse mount it doesn't do so many lookups.

Additional info:

Comment 2 Ira Cooper 2016-02-18 09:35:21 UTC
Please retest, we're not sure the bug is still there.

Comment 7 Amar Tumballi 2018-04-19 04:16:34 UTC
Closed the samba bugs in bulk when PM_Score was less than 0. As the team was working on few of them, opening all of them.


Note You need to log in before you can comment on or make changes to this bug.