Bug 1129277 - C++ example "server_reconnect.cpp" cannot be built
Summary: C++ example "server_reconnect.cpp" cannot be built
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Windows
medium
high
Target Milestone: 3.0
: ---
Assignee: Chuck Rolke
QA Contact: Petra Svobodová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 13:13 UTC by Petra Svobodová
Modified: 2014-09-24 15:12 UTC (History)
4 users (show)

Fixed In Version: qpid-cpp-0.22-47
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 15:12:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-6026 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Petra Svobodová 2014-08-12 13:13:39 UTC
Description of problem:
C++ example "server_reconnect.cpp" is not covered into "CMakeLists.txt" file, so no project file is generated by "run-cmake.bat" script.

Version-Release number of selected component (if applicable):
qpid-cpp-win-3.22.46.1-1

How reproducible:
100%

Steps to Reproduce:
1. Unzip the qpid-cpp-win packages.
2. Try to run "~\examples\examples-cmake\run-cmake.bat".
3. Check if all C++ examples (~\examples\messaging\*.cpp) have generated their project files.

Actual results:
"server_reconnect.cpp" examples have no project file.

Expected results:
All examples should have their project files.

Comment 1 Justin Ross 2014-08-18 13:56:58 UTC
Chuck, please assess.

Comment 2 Chuck Rolke 2014-08-18 19:26:38 UTC
server_reconnect.cpp was added in September 2013. Some project stuff was added for visual studio but nothing was added to the WinSDK. There's a cmakelists.txt in the winsdk that needs one line added to it to build the associated executable.

Comment 3 Chuck Rolke 2014-08-20 17:33:09 UTC
trivial fix r1619170

Comment 5 Petra Svobodová 2014-08-29 12:34:23 UTC
All example code including "server_reconnect" in the qpid-cpp-win* packages can be built.

Verified on qpid-cpp-win-3.22.47.1-1 on Windows7-x86 and x64, WindowsXP-x86, Windows Server2003-x86 and x64, Windows Server2008-x86, x64 and R2.

--> VERIFIED

Comment 6 errata-xmlrpc 2014-09-24 15:12:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.