Bug 1129306 - provisioning leads into a infinite loop of installation after REALM Integration
Summary: provisioning leads into a infinite loop of installation after REALM Integration
Keywords:
Status: CLOSED DUPLICATE of bug 1129463
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning
Version: 6.0.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 14:50 UTC by Kedar Bidarkar
Modified: 2017-02-23 21:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 14:41:15 UTC


Attachments (Terms of Use)

Description Kedar Bidarkar 2014-08-12 14:50:59 UTC
Description of problem:

Provisioning of rhel65 with the below content

a) from RH content provider
RHEL65
b) from custom content 
RHCOMMON   [ for katello-agent and puppet packages]

c) Create an activation_key with the above both the subscriptions
d) Create a host_group and attach the above activation_key to the host_group
e) Use the above host_group, while provisioning a rhel65 box

NOTE: I could only test it for now for rhel65. As this is a lengthy process will update when encounter issues with rhel5 or rhel7.


Version-Release number of selected component (if applicable):
sat6-GA-snap4

How reproducible:
always.

Steps to Reproduce:
1.
2.
3.

Actual results:
provisioning goes in an infinite loop. that is os installation goes in a loop.
Using a AK and CV with just rhel65 content/subscription has no issues.

Expected results:
Should be possible to install katello-agent and puppet and avoid the infinite loop.

Additional info:

Comment 1 Kedar Bidarkar 2014-08-12 14:52:42 UTC
this issue is seen when I am trying with REALM Integration.

I need to try without REALM Integration. If someone confirms it that would be helpful.

Comment 2 RHEL Product and Program Management 2014-08-12 15:03:23 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 Kedar Bidarkar 2014-08-12 19:56:02 UTC
stbenjam suggested that the problem is "puppet is telling foreman the wrong name".

[root@omgwtfbbq02 ~]# facter fqdn
omgwtfbbq02.englab.pnq.redhat.com
[root@omgwtfbbq02 ~]# hostname
omgwtfbbq02.katellolabs.org

Comment 5 Kedar Bidarkar 2014-08-13 14:38:42 UTC
Workaround for now.


I had to use fix_hosts to over come this issue and slightly modify it as below.

NOTE: 
1) The below step 2) is required for REALM/IPA  Integration as ipa-client-install checks for <hostname>.<domainname> and clearly states that FQDN is preferred.
2) Modified few instances of s/@host.shortname/@host/  in fix_hosts 
3) Added:
  <%= snippet 'fix_hosts' %> before                                      
  <%= snippet "subscription_manager_registration" %> in
 'Satellite Kickstart Default' template.

Below is the modified fix_hosts template which helped solve this issue for now.

<%#
kind: snippet
name: fix_hosts1
%>
echo "<%= @host %>" > /etc/hostname
hostname <%= @host %>
cat > /etc/hosts << EOF
<%# simple snippet to generate /etc/hosts when provisioning image based systems -%>
127.0.0.1   <%= @host %> <%= @host.shortname %> localhost localhost.localdomain
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
EOF

Comment 6 Kedar Bidarkar 2014-08-13 14:41:15 UTC

*** This bug has been marked as a duplicate of bug 1129463 ***


Note You need to log in before you can comment on or make changes to this bug.