Bug 1129308 - package optional sugar backup control panel
Summary: package optional sugar backup control panel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: sugar
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Simon Schampijer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 14:56 UTC by Gonzalo Odiard
Modified: 2014-08-13 09:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 09:06:31 UTC


Attachments (Terms of Use)
Proposed enhancement to the spec (1.17 KB, patch)
2014-08-12 14:59 UTC, Gonzalo Odiard
no flags Details | Diff

Description Gonzalo Odiard 2014-08-12 14:56:25 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Gonzalo Odiard 2014-08-12 14:59:00 UTC
Created attachment 926089 [details]
Proposed enhancement to the spec

Comment 2 Gonzalo Odiard 2014-08-12 15:03:18 UTC
Sugar 0.102 add a new control panel section to do backup/restore of the Journal. The proposed patch creates the needed rpm.

Another change important in sugar 0.102 is the use of dconf. I think would be good add it as a dependency in the rpm. Many times sugar will be installed with Gnome, but in other cases, like SoaS or small devices like the XO-1, that is not true.

Comment 3 Peter Robinson 2014-08-12 15:53:57 UTC
> Another change important in sugar 0.102 is the use of dconf. I think would
> be good add it as a dependency in the rpm. Many times sugar will be
> installed with Gnome, but in other cases, like SoaS or small devices like
> the XO-1, that is not true.

Missed that, does that mean that GConf2 is no longer needed?

Comment 4 Gonzalo Odiard 2014-08-12 16:22:31 UTC
(In reply to Peter Robinson from comment #3)
> > Another change important in sugar 0.102 is the use of dconf. I think would
> > be good add it as a dependency in the rpm. Many times sugar will be
> > installed with Gnome, but in other cases, like SoaS or small devices like
> > the XO-1, that is not true.
> 
> Missed that, does that mean that GConf2 is no longer needed?

We still use GConf to keep compatibility with old activities.

Comment 5 Peter Robinson 2014-08-12 16:51:43 UTC
(In reply to Gonzalo Odiard from comment #4)
> (In reply to Peter Robinson from comment #3)
> > > Another change important in sugar 0.102 is the use of dconf. I think would
> > > be good add it as a dependency in the rpm. Many times sugar will be
> > > installed with Gnome, but in other cases, like SoaS or small devices like
> > > the XO-1, that is not true.
> > 
> > Missed that, does that mean that GConf2 is no longer needed?
> 
> We still use GConf to keep compatibility with old activities.

By old activities do you mean gtk2 Activities? If so the dependency can go there. If the core sugar shell no longer depends on GConf2 I can remove it as a build dep. So is it used by the shell?

Comment 6 Gonzalo Odiard 2014-08-12 17:11:04 UTC
Is used by the shell, because we save the configs in dconf _and_ in gconf.

There are a few configs not ported yet, and we will continue updating the config for compatibility with old activities (who read the configs) for a time.

Comment 7 Peter Robinson 2014-08-13 09:06:31 UTC
Fixed in F-21+


Note You need to log in before you can comment on or make changes to this bug.