Bug 1129376 - Activation keys useless without environment
Summary: Activation keys useless without environment
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: Unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-12 15:20 UTC by Matej Kollar
Modified: 2019-02-25 21:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-12 15:30:08 UTC


Attachments (Terms of Use)

Description Matej Kollar 2014-08-12 15:20:36 UTC
Description of problem: Activation keys are useless without lifecycle environment set.

So why not make this parameter mandatory? Or make "Library" the default one...


How reproducible: always/deterministic


Steps to Reproduce:
  1. Create activation key without environment (via api you can even
     set content view without setting environment).
  2. Try to use it

Actual results:

# subscription-manager register --org="Red_Hat_SatTeam" --activationkey="1-akakakak"
At least one activation key must have a lifecycle environment and content view assigned to it
# subscription-manager register --org="Red_Hat_SatTeam" --activationkey="1-akakakak" --environment="Library"
Error: Activation keys do not allow environments to be specified.


Expected results: Either Library is used by default OR you can specify --environment with activation key OR it would not be possible to create useless activation key

aditional info: sat6-Satellite-6.0.4-RHEL-6-20140730.0-Satellite-x86_64-dvd1.iso

Comment 1 RHEL Product and Program Management 2014-08-12 15:23:27 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 sthirugn@redhat.com 2014-08-12 15:25:17 UTC
Last week, I heard that activationkey can be paired in subscription-manager commands like:

subscription-manager register --activationkey PREMIUM-JBOSS-STACK --activationkey PRODUCTION-ENVIRONMENT

So one activation key will hold my subscriptions and other will hold my environments.  I never tried this though.  

If this is a valid scenario, then it is valid to allow activation key to be created without environment or content view.

Comment 4 Tom McKay 2014-08-12 15:30:08 UTC
This is working as intended. Multiple activation keys may be specified to subscription-manager and at least one must reference a content view.


Note You need to log in before you can comment on or make changes to this bug.